Jump to content

[v13.1] No soldiers can be hired & soldier counter is wrong


Recommended Posts

I created a base and somehow got into a state where no soldiers could be hired - I could hit the counter and the system would increase the charge, but the number of hired soldiers would remain at zero. See attached screenshot 1.

xeno_soldiers1.jpg

Then when I tried to increment the worker counter, it updated the soldier counter as well - both the number of soldiers and workers to be hired incremented, but I was not charged for the soldiers. They also didn't get hired when i did this. See attached screenshot 2.

xeno_soldiers2.jpg

Finally, until I used the start new game & then load the existing one, I couldn't get more soldiers to hire.

xeno_soldiers1.jpg

xeno_soldiers2.jpg

xeno_soldiers1.jpg.473faad9934a10ec3bd1b

xeno_soldiers2.jpg.9871d6ed3f5d48c4fed7b

Link to comment
Share on other sites

I noticed that when you hire engineers soldier count is also increased. However if you hire soldiers - that counter switches to blue, but never grows. It still allows you to select the exact number of soldier you`ve clicked when you hit the hire button.

This is my first base on a fresh game. Also on 1280x1024 i can`t see the numbers correctly. They are misplaced. The same goes for research screen and engineering screen.

Link to comment
Share on other sites

On a new game, with the first base, I could click the solider counter but it did not count up. I got the solider hire board, with a list of soliders to hire from. After hiring, the solider counter correctly showed the current number of soliders with total soliders breakceted behind the current number.

Link to comment
Share on other sites

I've had the same problem as Okim... when I hired more engineers the numbers of soldiers went up between the up and down arrows, they didn't have any cost associated with them, and didn't appear to be counting towards barracks space. When I hit hire I got the number of engineers i had order sent to me, and the soldier number reverted to the actual number of soldiers I had... so it just looks like a display/counter issue.

First base (2 others had aircraft but no barracks), about mid first month... doesn't seem to affect scientist hirings.

Link to comment
Share on other sites

It should be fixed in the next build.

The bug is still there in version 13.2.

In my repro it was a new game, first base.

Clicking on the increase technicians button both the technicians and the soldiers number are increased.

Clicking on the increase soldiers button only the wages amount goes up.

After a reload, clicking on hire soldiers, the soldier list is empty...

Link to comment
Share on other sites

  • 2 weeks later...

same problem here. have got plenty of space (2nd living room with 44 beds left). clicking on hire, there's no soldier name in the hire list. changing the technician slider would have the soldier slider change but without any effect.

- first game

- first base

- build V13 (31 july 2012) (alpha 1192, build 32 as per Desura properties)

Link to comment
Share on other sites

I too got this bug after a while into my game. Originally i could hire soldiers, but suddenly when i try to recruit it get to the screen where it tells me to pick X amount of soldiers from the list. Problem is the list is empty.

Hiring scientists and technicians is not a problem, but i just get a blank list for soldiers.

Link to comment
Share on other sites

There is a workaround (briefly mentioned by OP) that was mentioned in another thread, but since I couldn't find that one I'll post it here:

Start a new game, place a base, and hire one soldier. Load your old saved game that didn't have any soldiers to hire and the list should now be populated. The downside to this workaround is that you can hire duplicates of the same soldier across multiple bases and your chinooks start showing weird things as far as how many and which soldiers are assigned to them. However, at least you'll have the soldiers to proceed with the game.

Link to comment
Share on other sites

i also have this problem (first base, new game and build V13,2 )

when i hire soldiers the counter rise, get blue and look funny. i cant get pics in here :( but it looks somthing like this

soldier 10 before i hire

soldier 11(+1) after i hire 1

soldier 12(+2) after i hire 2 and so on

it take the money, but i dont get any soldiers :confused:

Link to comment
Share on other sites

There is a workaround (briefly mentioned by OP) that was mentioned in another thread, but since I couldn't find that one I'll post it here:

Start a new game, place a base, and hire one soldier. Load your old saved game that didn't have any soldiers to hire and the list should now be populated. The downside to this workaround is that you can hire duplicates of the same soldier across multiple bases and your chinooks start showing weird things as far as how many and which soldiers are assigned to them. However, at least you'll have the soldiers to proceed with the game.

Quoting to make sure people realise there is a workaround for this.

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...