Jump to content
Charon

[1.65/X.CE V0.35.0] X-Division 1.00 Beta

Recommended Posts

yes, i was just daydreaming..because i know how annoying could the AI be, and the behaviour im "suggesting" (and every other kind of HIGH PATTERN) its pretty difficult if not impossible to implement xD

Share this post


Link to post
Share on other sites

crash!! 2 times on different maps. Linux (last GOG version on current date)

last log:

INFO: MOD ERROR: An element to replace does not exist: Weapon
INFO: MOD ERROR: Merging XML for weapons_gc.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: tilemap
INFO: MOD ERROR: Merging XML for maps/ufos/landed/scout/scout_layout.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: tilemap
INFO: MOD ERROR: Merging XML for maps/ufos/Landed/scout/scout_layout.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/UFO/walls/door_se_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/UFO/walls/door_nw_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/UFO/scout/scout_door_se_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: {GCLoading}: AddToScene (ufo submap) took 1.000000sec
INFO: {GCLoading}: AddToScene (dropship submap) took 0.000000sec
INFO: {GCLoading}: AddToScene (layer 0) took 0.000000sec
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/props/snowpine_3_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/props/snowpine_1_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/props/snowpine_2_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/cover/rock_cover_1x1_3_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/cover/rock_cover_1x1_2_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/props/snowpine_4_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/cover/rock_cover_1x1_1_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/cover/rock_cover_1x1_7_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/cover/rock_cover_1x1_6_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: {GCLoading}: AddToScene (layer 1) took 1.000000sec
INFO: {GCLoading}: AddToScene (layer 2) took 0.000000sec
INFO: {GCLoading}: AddToScene (layer 3) took 1.000000sec
INFO: MOD ERROR: An element to update does not exist: Rank
INFO: MOD ERROR: Merging XML for aiprops.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for units/xenovehicles/VEHICLE.HUNTER/VV.MACHINEGUN/vehicle_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: An element to replace does not exist: Tileset
INFO: MOD ERROR: Merging XML for missiontypeprops_gc.xml from mod mods/x-division 0.99 beta/ failed.
 

Share this post


Link to post
Share on other sites
2 minutes ago, peter said:

crash!! 2 times on different maps. Linux (last GOG version on current date)

last log:

INFO: MOD ERROR: An element to replace does not exist: Weapon
INFO: MOD ERROR: Merging XML for weapons_gc.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: tilemap
INFO: MOD ERROR: Merging XML for maps/ufos/landed/scout/scout_layout.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: tilemap
INFO: MOD ERROR: Merging XML for maps/ufos/Landed/scout/scout_layout.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/UFO/walls/door_se_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/UFO/walls/door_nw_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/UFO/scout/scout_door_se_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: {GCLoading}: AddToScene (ufo submap) took 1.000000sec
INFO: {GCLoading}: AddToScene (dropship submap) took 0.000000sec
INFO: {GCLoading}: AddToScene (layer 0) took 0.000000sec
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/props/snowpine_3_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/props/snowpine_1_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/props/snowpine_2_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/cover/rock_cover_1x1_3_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/cover/rock_cover_1x1_2_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/props/snowpine_4_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/cover/rock_cover_1x1_1_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/cover/rock_cover_1x1_7_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for tiles/arctic/cover/rock_cover_1x1_6_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: {GCLoading}: AddToScene (layer 1) took 1.000000sec
INFO: {GCLoading}: AddToScene (layer 2) took 0.000000sec
INFO: {GCLoading}: AddToScene (layer 3) took 1.000000sec
INFO: MOD ERROR: An element to update does not exist: Rank
INFO: MOD ERROR: Merging XML for aiprops.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: Element without MODMERGE has both children and attributes: spectre
INFO: MOD ERROR: Merging XML for units/xenovehicles/VEHICLE.HUNTER/VV.MACHINEGUN/vehicle_spectre.xml from mod mods/x-division 0.99 beta/ failed.
INFO: MOD ERROR: An element to replace does not exist: Tileset
INFO: MOD ERROR: Merging XML for missiontypeprops_gc.xml from mod mods/x-division 0.99 beta/ failed.
 

My keen senses tell me that you have other mods activated that you shouldnt and that they are not in the right modloader order, check the modloader pic again.

I think this is a linux problem, people on linux believe that mod order isnt important, i might have to clarify this.

Share this post


Link to post
Share on other sites

>My keen senses tell me that you have other mods activated that you shouldnt and that they are not in the right modloader order, check the modloader pic again.

>think this is a linux problem, people on linux believe that mod order isnt important, i might have to clarify this

No one mod. It my first.

I not add depend map pack:

Khalls´s Tundra Tileset
Random Map Pack Arctic Collection
Random Map Pack Desert Style
Random Map Pack Farm Edition
Restored Community Map Pack
Skitsos Alien Base Booster Pack
Skitsos Improved Tile Art Pack
Skitsos Ultimate Mega Mix Map Pack 2000

Sorry)))

Share this post


Link to post
Share on other sites

Wait what ? not one mod ? but you need XCE

ah, ok, wait you are on the gog version ?

So you need everything.

1. Base 1.65 version

2. XCE 0.34.1

3. Everything you additionally need with the XCE pack

4. X-Division

5. right mod order, its still important

Share this post


Link to post
Share on other sites
26 minutes ago, Charon said:

Can you guys and girls give me feedback how often terror sites happen in days.

 

I did a fast forward to look at what tech tree had in reserve. Doing basically nothing from 12 September to 1 December (when I lost), I've seen one base assault and two terror attacks. On the other hand, I had about eight air terror missions, and boy were those painful. The Bomber Corvette doesn't joke.

Share this post


Link to post
Share on other sites
11 minutes ago, TideofKhatanga said:
43 minutes ago, Charon said:

Can you guys and girls give me feedback how often terror sites happen in days.

 

I did a fast forward to look at what tech tree had in reserve. Doing basically nothing from 12 September to 1 December (when I lost), I've seen one base assault and two terror attacks. On the other hand, I had about eight air terror missions, and boy were those painful. The Bomber Corvette doesn't joke.

Thank you.

Kepp it comeing !

Share this post


Link to post
Share on other sites

Another bug I think.

After researching the chemical grenade.  It does not show up in the Workshop.  The chemical rocket does show up after researching it.

 

On other matters:

General comment:  Research seems to go very quickly.  Maybe too quickly.  Or maybe it's just easy in the first months.

 

And I found I prefer to fight the Ceasan(spelling)...they sometimes carry stun weapons so after I kill one I equip with the stun weapon and try to stun everyone else.  The lizards don't carry stun weapons and I have not researched shock weapons yet.  So capturing one is VERY risky and I don't want to lose my experienced soldiers.  And the shock batons don't do enough unless I send in 4 or more soldiers against ONE lizard.

Share this post


Link to post
Share on other sites
3 minutes ago, Larry Burstyn said:

Another bug I think.

After researching the chemical grenade.  It does not show up in the Workshop.  The chemical rocket does show up after researching it.

fixed

4 minutes ago, Larry Burstyn said:

And I found I prefer to fight the Ceasan(spelling)...they sometimes carry stun weapons so after I kill one I equip with the stun weapon and try to stun everyone else.  The lizards don't carry stun weapons and I have not researched shock weapons yet.  So capturing one is VERY risky and I don't want to lose my experienced soldiers.  And the shock batons don't do enough unless I send in 4 or more soldiers against ONE lizard.

Congrats, you just broke the game. No, kidding, thats intended :). Yes, lizards are harder to catch and i would send 8 men against 1 lizard.

Share this post


Link to post
Share on other sites

Boy those morphs on ground terror missions are murder....lost my entire squad and tank....killed a lot of morphs but still lost.  Did not even get very far from the Chinook.  So far only one ground terror mission which is the last thing I done (did?) so I might replay it to see if a different tactic might work.

 

Boy those first two messages on this forum are LONG....my poor eyes cannot do that much reading without taking breaks.  But that is my problem and those messages carry a lot of info.

Share this post


Link to post
Share on other sites
3 minutes ago, Larry Burstyn said:

Boy those first two messages on this forum are LONG....my poor eyes cannot do that much reading without taking breaks.  But that is my problem and those messages carry a lot of info.

This is why they are perfectly structured. Take what you need and come back for more later.

 

Try it on a lower difficulty level ?

Edited by Charon

Share this post


Link to post
Share on other sites
16 minutes ago, Larry Burstyn said:

Boy those morphs on ground terror missions are murder....lost my entire squad and tank....killed a lot of morphs but still lost.  Did not even get very far from the Chinook.  So far only one ground terror mission which is the last thing I done (did?) so I might replay it to see if a different tactic might work.

If they didn't change from 0.98, the smaller xenomorph hate being in sight. You can litterally stare them down if they don't have the TU to kill you this turn, and keeping 360° vision around your squad will limit attacks.

Of course, that's less applicable in terror mission where they have backup. Also, the large ones are hell.

Share this post


Link to post
Share on other sites

Hi!

My game crashes every time after I type name for my first base just after new game start.

X-Division archive is not broken. I checked MD5.

Mods order is set as described in this topic. Screenshot http://take.ms/oiDoC

 

Also everything works perfectly without X-Division mods. I also did Xenonauts files recheck in Steam. It didn't help. OS version: Vindows7

Any suggestions?

---------------------------------------------------------------

ADDED: Nevermind. I deleted the whole game and installed it from scratch. Everything works fine now. 

Edited by morr

Share this post


Link to post
Share on other sites
30 minutes ago, morr said:

Hi!

My game crashes every time after I type name for my first base just after new game start.

X-Division archive is not broken. I checked MD5.

Mods order is set as described in this topic. Screenshot http://take.ms/oiDoC

 

Also everything works perfectly without X-Division mods. I also did Xenonauts files recheck in Steam. It didn't help. OS version: Vindows7

Any suggestions?

---------------------------------------------------------------

ADDED: Nevermind. I deleted the whole game and installed it from scratch. Everything works fine now. 

Heh i thought the last part is signature :). Enjoy the ride then!

Share this post


Link to post
Share on other sites

In game 30 of October 1979 and i've had I think 2 terror attacks. God they are fun times!

Bug Report

1. I'm finding the bottom of the corvette texture is not there. It matches the scenery of whatever it is landed on. As in instead of a metal looking floor, it is all grass on the inside!

2. Anti-matter MK1 Rifle isn't setup correctly. It has been researched and is buildable in workshop, but doesn't show up in armoury and will therefore cause crash on production.

Edited by Lament

Share this post


Link to post
Share on other sites
6 minutes ago, domein said:

Is there any regular download source? I would rather avoid mega malware installs.

There is no mega malware install, simply download it through your browser.

Share this post


Link to post
Share on other sites

I am really liking the theme of this mod! It gives me the Long War vibe, great work!

I ran into a bug with the Geoscape not allowing me to click on anything. Reading over this thread, I'm going to perform a fresh install and then triple check the mod loading order and start a fresh game, as it looks likely that this will resolve my issue.

I'm also in the belief that the shotguns maximum range is too short, I understand it from a design point making weapons more specific in their use gives more options to the player and requires greater planning. The shotgun range however feels like it is suitable for a sawn-off shotgun, a full length shotgun should have even just 4-5 more tiles on it's maximum range, in the early game my assault soldiers would often die simply trying to get to an effective range, even with LMG's providing suppression assistance. Maybe things change with higher tier weapons and armor, but I'm struggling to justify equipping a shotgun in phase1.

One other area where I am happy to offer my assistance is in regards to the X-pedia entries and little descriptions about the researches being missing at the moment or place holders are a big immersion breaker for me. If someone could PM me what would be required to provide assistance on this area I can see what I can do to help. I wouldn't consider myself an in depth lore writer but simple explanations about what the research team hope to achieve etc. should be easy enough, as well as I spend a lot of time spell checking peoples work and re-writing it if required.

Share this post


Link to post
Share on other sites

Hi!

Bug report: I researched Phase 1 Chemical Rockets & Grenades. Now I can Produce Chemical rockets, but I can't produce Chemical Grenades. Is it a bug?

What is "Phase I" section desined for? I produced Alien Scout DSB, Alien Phaser Rifle and Alien Lightning Rifle in workshop but I can't find them in Storeroom. My troops can't equip them too.

Edited by morr

Share this post


Link to post
Share on other sites
6 hours ago, Sectiplave said:

I am really liking the theme of this mod! It gives me the Long War vibe, great work!

I ran into a bug with the Geoscape not allowing me to click on anything. Reading over this thread, I'm going to perform a fresh install and then triple check the mod loading order and start a fresh game, as it looks likely that this will resolve my issue.

I'm also in the belief that the shotguns maximum range is too short, I understand it from a design point making weapons more specific in their use gives more options to the player and requires greater planning. The shotgun range however feels like it is suitable for a sawn-off shotgun, a full length shotgun should have even just 4-5 more tiles on it's maximum range, in the early game my assault soldiers would often die simply trying to get to an effective range, even with LMG's providing suppression assistance. Maybe things change with higher tier weapons and armor, but I'm struggling to justify equipping a shotgun in phase1.

One other area where I am happy to offer my assistance is in regards to the X-pedia entries and little descriptions about the researches being missing at the moment or place holders are a big immersion breaker for me. If someone could PM me what would be required to provide assistance on this area I can see what I can do to help. I wouldn't consider myself an in depth lore writer but simple explanations about what the research team hope to achieve etc. should be easy enough, as well as I spend a lot of time spell checking peoples work and re-writing it if required.

Welcome Sectiplave. For your game problem, as i said please try a new game and mod install and mave a mod list exactly as we showed here.

For Entries, Charon will speak with you soon.

5 hours ago, Lament said:

Bug Report

1. Buzzard armour researched, but no ability to manufacture or ufopedia

Hmm.. it looks working as code, but we will test. Thanks.

33 minutes ago, morr said:

Hi!

Bug report: I researched Phase 1 Chemical Rockets & Grenades. Now I can Produce Chemical rockets, but I can't produce Chemical Grenades. Is it a bug?

What is "Phase I" section desined for? I produced Alien Scout DSB, Alien Phaser Rifle and Alien Lightning Rifle in workshop but I can't find them in Storeroom. My troops can't equip them too.

Hey

Can't produce means, there is no manufacture?

Phase 1 means all manufactures you will have at phase 1. Those are all Disassemble protocols to get the items you need for your own. Both as plane and weapon.

Share this post


Link to post
Share on other sites
20 minutes ago, drages said:

Can't produce means, there is no manufacture?

Yes. There is a Chemical Rocket in "BOOM & SLICE" workshop section, but there is no Chemical Grenade there.

Share this post


Link to post
Share on other sites
10 hours ago, Charon said:
10 hours ago, domein said:

Is there any regular download source? I would rather avoid mega malware installs.

There is no mega malware install, simply download it through your browser.

I would love to, but this mega only offers to either instaill their browser plugin or install their download manager, there is no option to simply download the file.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×