Jump to content
Charon

[1.65/X.CE V0.35.0] X-Division 1.00 Beta (1.00.10)

Recommended Posts

Are you sure that's how the tree block example goes? Because, if that is true, then each piece of cover essentially provides its cover bonus twice; first on the "does the bullet fly towards the alien" calculation and second on the "is the cover hit instead" calculation. Which just seems odd.

Share this post


Link to post
Share on other sites
48 minutes ago, Dagar said:

Are you sure that's how the tree block example goes? Because, if that is true, then each piece of cover essentially provides its cover bonus twice; first on the "does the bullet fly towards the alien" calculation and second on the "is the cover hit instead" calculation. Which just seems odd.

That is exactly what i am stating.

The bonus gets once applied as "obscuring vision" and it gets additionally calculated for every bullet which passes it. And its not odd at all, a tree standing in your way irl blocks your vision AND can block/manipulate your shot.

Share this post


Link to post
Share on other sites

Ohh, I get it - cover reduces your adcuracy twice: first for blocking your view, and second for blocking your bullets. And only the view-blocking is computed in the to-hit chance shown next to the reticule; the bullet-blocking chances are instead shown separately next to each obstacle in the way, and are only checked against if the bullet happens to actually cross them after roling for fire dispersion.

 

BTW, I can’t replicate your result of 67.5% to shoot at targeted tile from the first one diagram, pre-bulletblocking. You sure it’s not 51.5%?

Edited by Mr. Mister

Share this post


Link to post
Share on other sites
2 hours ago, Mr. Mister said:

BTW, I can’t replicate your result of 67.5% to shoot at targeted tile from the first one diagram, pre-bulletblocking. You sure it’s not 51.5%?

I tried to look up how i got to this number, but it should be wrong. The correct calculation is 135 * 0.9 * 0.3 = 36.45.

No, 135 * 0.9 - 70 = 51.5 is not correct, its always a multiplication.

 

Happy New YEAR.

Share this post


Link to post
Share on other sites

@PALU As far as i have seen you didnt take the new entries for the powersource and alenium ? Anyway, reinstate the XCE entries and give me any new version for approval beforehand for both entries if you are still working on them.

Share this post


Link to post
Share on other sites

Newbie to this mod here, sorry if its been asked before but a quick search turned up nothing.  I just got the first lore report on the caesan guard corpse, and the avalanche torpedo, and both of their xenopedia entries just say 'description', nothing else.  Is this normal, or the sign of something like a bad installation/setup?  

Share this post


Link to post
Share on other sites

Hi your mod installer contains loads of thumbs.db files, these are not needed since they are made by your OS..

Edited by logicon

Share this post


Link to post
Share on other sites
6 hours ago, Ruthless Reuban said:

Avalanche torpedo should have longer description. I guess you didn't start game before installing X-division?

I did start the game once before installing.  Fresh install, too, unsubbed from steam workshop mods as well.

Share this post


Link to post
Share on other sites
20 minutes ago, Ion Mage said:

I did start the game once before installing.  Fresh install, too, unsubbed from steam workshop mods as well.

You did install X.CE 0.35 too? I have no idea about Steam workshop mods however.

Share this post


Link to post
Share on other sites
1 minute ago, Ruthless Reuban said:

You did install X.CE 0.35 too? I have no idea about Steam workshop mods however.

Yup, running XCE 0.35.

Share this post


Link to post
Share on other sites

Lore: The latest file posted (30:th of December) contains the texts as discussed, and thus can be reviewed at any time.

Share this post


Link to post
Share on other sites

Sorry, but what latest file, and where?  Couldn't find anything in the OP/install instructions (assuming you were talking to me).

Share this post


Link to post
Share on other sites

@Ion Mage : No, my post is a response to Charon's demands, not your issues. Unfortunately I don't know what may have caused your issue or how to resolve it. If it happened to me I'd wipe the installation completely and reinstall from scratch, following the installation instructions very closely, checking every step, and hoping that would resolve it.

Share this post


Link to post
Share on other sites

Just did that actually.  Same outcome.  Not only uninstalled, but completely wiped the xenonauts directory, and redownloaded it entirely.  I have applied the latest x-division patch too.  I don't presume I need to subscribe to the steam workshop entry for x-division, correct?  Its description seems to indicate its only there to advertise the mod's existence, since workshop doesnt let you post 6.6gb mods, so I doubt it, but its all I can think to ask at the moment.

 

Edit:  Just took a look inside the xenopedia.xml file from the extracted installer (for both the core mod as well as the patch), and it seems that the description just says 'description' there as well;

<Row ss:Height="51">
    <Cell ss:StyleID="s72"><Data ss:Type="String">AV.AVALANCHE</Data></Cell>
    <Cell ss:StyleID="s73"><Data ss:Type="String">Avalanche Torpedo</Data></Cell>
    <Cell ss:StyleID="s73"><Data ss:Type="String">xenopediaimages/avalanche_torpedo</Data></Cell>
    <Cell ss:StyleID="s73"><Data ss:Type="String">Aircraft Torpedo</Data></Cell>
    <Cell ss:StyleID="s73"><Data ss:Type="String">ACW</Data></Cell>
    <Cell ss:StyleID="s73"><Data ss:Type="String">Description</Data></Cell>
   </Row>

So, I don't think its a botched install.  Did I get the wrong patch?  I have the 1.00.01 patch, which as far as I can tell is the most recent one.

Edited by Ion Mage

Share this post


Link to post
Share on other sites

@Ion MageYes, you've got the wrong patch.

The latest patch is 1.00.10, posted about two forum pages before this one (it's the latest of a number of patches called 1.00.10). There are several versions of xenopedia.xml in the install, because there's one from the base game, one from X:CE, one from X-Division, and one from Lore++ (and I can't swear that's the complete set). The 1.00.01 patch doesn't contain my version, which is yet another override, but the 1.00.10 one does.

Share this post


Link to post
Share on other sites

Downloaded 1.00.10, and I got a proper avalanch description.  Might be good to edit the instructions in this topics OP, it lists 1.00.01 as most recent, currently.  Anyways, thanks.

Edited by Ion Mage

Share this post


Link to post
Share on other sites

@PALU At the time of my request i already reviewed your latest version, and i would still ask you to reinstate the original entry from XCE/vanilla effective immediately, and to send me any further changes beforehand for me to review and work on them. Changing vanilla lore is a hot topic and not something i take lightly. Thank you.

Share this post


Link to post
Share on other sites

This should be bug I think. I used lightly modded (some settings tweaked) X-Division 1.00.10 install. On second phase sent my "rookie" platoon to capture small UFO with couple of reapers. One rookie got infected, so I shot down that zombie and it came a pile of blood. Everyone else survived. Now for the fun part. After mission was succesfull, that zombified soldier was revived!

I thought that my light modifications are to blame and tried with fresh X-division install with 1.00.10 of course. Loaded save just before that battle began (Geoscape save) and let aliens zombify several soldiers. Again, some soldiers that were zombified and shot down were revived.

This is nothing game breaking of course, I just fire those "revived zombies".

Edited by Ruthless Reuban

Share this post


Link to post
Share on other sites

Yeah, there are some bugs. You can (or maybe could) get back downed soldiers from an unsuccessful base raid, for example.

  • Like 1

Share this post


Link to post
Share on other sites

Lore: The Alenium and Powersource entries have been removed as to not override any entries. I neither know nor care if the X-Division version differs from vanilla and/or X:CE, as I don't have any authority over any of those.

xenopedia.xml

Edited by PALU

Share this post


Link to post
Share on other sites
32 minutes ago, PALU said:

Lore: The Alenium and Powersource entries have been removed as to not override any entries. I neither know nor care if the X-Division version differs from vanilla and/or X:CE, as I don't have any authority over any of those.

xenopedia.xml

Here you go: xenopedia (1).xml I just added the original entries again.

 

Edit:

Quote

or you will invite attack by this weapon.

an attack

Edited by Charon

Share this post


Link to post
Share on other sites

I think the lore message was misunderstood: I deliberately removed the entries as you're not satisfied with my attempts (despite high praise for Mr. Mister's suggestion, which I incorporated), and the original versions aren't up to my standard, so I leave it up to you to come up with a version you like without any interference from me.

Campaign wise I'm slowly slogging through: third wave of phase 4, with the second wave being really nasty, as it contained a base attacking terror mothership as well a previous phase terror dreadnought on a terror mission (and to my surprise I actually managed to bring the mothership down: it was in the air long enough to be hit by almost all the bombers I had [damaging them badly, of course], including some that had taken on the terror dreadnought, reloaded, and flown over the Atlantic Ocean), plus an Andron bomber that surprised me with containing terror robodogs (the boss looked like a normal boss, but the Androns managed to put both of the "regular" Androns in the command center in a position where I had to eliminate them before the boss [and I didn't know they were only 2], so the battle was over when the shield went down (and the shield took a suspicions amount of punishment, as well as the weapon being fishy: no sound and minimal shield damage on my shield bearer). Something odd is that I'd recovered no alien interceptors from 3 escort missions during the two first waves, despite being over land, and only one each from the two escort missions of wave 3. The two interceptor wings of wave 3 yielded 3 alien craft each, though.

Share this post


Link to post
Share on other sites
3 hours ago, PALU said:

I think the lore message was misunderstood: I deliberately removed the entries as you're not satisfied with my attempts (despite high praise for Mr. Mister's suggestion, which I incorporated), and the original versions aren't up to my standard, so I leave it up to you to come up with a version you like without any interference from me.

HAH. You think i am going to touch it ? Or let somebody else do it ? You are the first and last X-Division lore writer and if you cant put it into the lore it won´t be there. You decide whether thats an honor or a curse ;).

 

How did you like the new and revised mothership ? We especially revised before the 1.00 version, and i dont even think we had enough time to throughly test it to the extreme, eg. i couldnt test it. The archelon needs a slight buff in either speed or manouverability, so let me know what you think.

About the odd andron and fighter stuff. Odd. But it shouldnt happen this way. Did you get both the alien interceptor and heavy interceptor ?

 

Cheers Mate. You look to be close to the finish line.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×