Jump to content

Forums Update!


Chris
 Share

Recommended Posts

The observant among you will probably have noticed that the forums look different these days. Unfortunately this is because our old forums (which had somewhat out of date software) were hacked and deleted by some kind of bot.

Thankfully, all the posts and users were backed up so we (and by "we" I mean @Solver) were able to recover the posts and users. Unfortunately not all the attachments appear to have survived, but Solver is looking into salvaging what he can as we speak.

Because our old forum theme doesn't work with our updated forum software, I had to buy a new theme for the forums. Actually, I bought two - and I ended up using the one that looks less cool but is much easier to read. Hopefully you guys like it; it should work better on mobile than it did previously anyway!

If you experience any issues with the new forums please just let us know in this thread and we'll do what we can to sort them out.

Link to comment
Share on other sites

1 minute ago, Charon said:

So I guess i will wait until @Chrisis finished changing stuff in the background and then come back ? Come back tomorrow and comment ?

I'm pretty much done now, so comment away.

I'm trying to figure out how to allow users to manually switch between the current theme and the one I had set about 15 minutes ago, so people can choose the other look if they prefer. The software doesn't seem to like that very much though so not 100% sure I can make it happen.

Link to comment
Share on other sites

Cuz things keep changing constantly. Rights, Layout and stuff. Lost the right to change between "Light" and Dark theme again. Also lost the right choose the Solid Background color.

Need a hand ?

Link to comment
Share on other sites

Anyway, the major issue i can see is that the colors of the X-Division main thread are all messed up. Im not sure how to fix this yet, or when the forum is stable enough to start fixing it.

Unbenannt.thumb.png.bff0d8cd8d303f507eeb33d4b19245ac.png

We want to keep it presentable, in both themes.

Link to comment
Share on other sites

1 hour ago, Charon said:

Anyway, the major issue i can see is that the colors of the X-Division main thread are all messed up. Im not sure how to fix this yet, or when the forum is stable enough to start fixing it.

We want to keep it presentable, in both themes.

There shouldn't be anything changing with the forum visuals now. It doesn't look like the light / dark switcher wants to work, so this will be the only forum skin you need to worry about!

Link to comment
Share on other sites

@ Chris The completed mod section has a section to the right with some stats. It looks good at first, until your realise that it takes 30% of the space away.

Unbenannt.thumb.png.a10641617a4fed23de773910a660934c.png

Would be much obliged if that got removed, for all instances across the forum.

 

While "i" dont really need a light/dark theme switch, i think its a functionality that a forum should have. As i know from experience it is possible to activate that switch, as it was switchable before. So maybe you look into that when you have some time.

Link to comment
Share on other sites

28 minutes ago, Charon said:

@ Chris The completed mod section has a section to the right with some stats. It looks good at first, until your realise that it takes 30% of the space away.

Would be much obliged if that got removed, for all instances across the forum.

 

While "i" dont really need a light/dark theme switch, i think its a functionality that a forum should have. As i know from experience it is possible to activate that switch, as it was switchable before. So maybe you look into that when you have some time.

Hmm, yeah, that sidebar is annoying. Weirdly it only seems to be triggered on long threads but is everywhere on the site that a sufficiently long thread (50 posts?) exists.

I can't see an option to disable it but I'll have another look later today. Not sure if it's a default Invision forum option, or something unique to this theme.

EDIT - ah, there we go. Fixed it.

Link to comment
Share on other sites

I looked at the wrong color scheme problem again, and i have come to the conclusion that rewriting the thread is problematic, not only because i cant edit some posts, because they are not made by me, but also because we are solving the wrong problem. Excluding X-Division there are a lot of mods which presentation was based on the light theme, and they would suffer from the same problem. Some threads are made based on the dark theme, and some are based on the light theme. The proper solution is to enable users to switch to the appropriate background, of which the basic themes are dark letters on light background, and light letters on dark background, and not to edit each individual post. Apart from that setting a custom background color, which is possible, is neat, but not required.

The fluidth width and bigger fonts options are a great addition.

Profile pictures are loading in abnormally slowly, and late. Additionally sometimes they have weird representation. You might want to look into that. You want to load in pictures first, then the rest.

Unbenannt.thumb.png.f8039e8eaeab753a808d033b8752a36f.png

 

This is a common nitpick with software that i have, and that extends to the whole unviability of windows 10, but if you want to load a "window" of any kind, and you render the window first with a white background, you flash the user, especially with a dark theme. The solution to that is pretty simply. You load the window per default with a black background. This is present on this forum as well, and is a minor point, but one that i would wish software would have per default.

 

Link to comment
Share on other sites

You cant see the number of upvotes somebody has below the profile anymore, though whether that information is actually informative, or just an ego thing is up for debate.

You cant directly see activity when hovering over a name anymore. Might be minor.

Link to comment
Share on other sites

3 hours ago, Charon said:

I looked at the wrong color scheme problem again, and i have come to the conclusion that rewriting the thread is problematic, not only because i cant edit some posts, because they are not made by me, but also because we are solving the wrong problem. Excluding X-Division there are a lot of mods which presentation was based on the light theme, and they would suffer from the same problem. Some threads are made based on the dark theme, and some are based on the light theme. The proper solution is to enable users to switch to the appropriate background, of which the basic themes are dark letters on light background, and light letters on dark background, and not to edit each individual post. Apart from that setting a custom background color, which is possible, is neat, but not required.

The fluidth width and bigger fonts options are a great addition.

Profile pictures are loading in abnormally slowly, and late. Additionally sometimes they have weird representation. You might want to look into that. You want to load in pictures first, then the rest

 

This is a common nitpick with software that i have, and that extends to the whole unviability of windows 10, but if you want to load a "window" of any kind, and you render the window first with a white background, you flash the user, especially with a dark theme. The solution to that is pretty simply. You load the window per default with a black background. This is present on this forum as well, and is a minor point, but one that i would wish software would have per default.

 

Hmmm. The current theme will be the default skin for the forums, though, and the one 90% of people will use even if I do get a dark / light swapper set up - particularly people who are coming here just to download X:CE.

I don't think that will be a genuine fix for the issue if threads don't display well on a dark background, imo at least.

Link to comment
Share on other sites

The landing page for the download section is a bit empty. You might think of revising that.

Some pictures in there got eaten by the bots.

The community edition got its own category, which ... i dont know how i feel about that but i think it should be properly represented.

I can confirm the 0 bytes bug addressed on reddit when trying to download the 35.1.zip. Propably something for @ Solver.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...