Jump to content
Sign in to follow this  
Moonfire

[V15.1 - Ground Combat] Fog of war stopped clearing

Recommended Posts

I was in a ground mission for a UFO I had shot down when the fog of war stopped clearing for the soldiers I was moving around. There wasn't any obvious reason for this, and the issue cleared up when I saved and reloaded. I haven't been able to reproduce this and it doesn't seem to have been preserved in a save file, but I did grab a screenshot where I had moved MARS into a fogged area that didn't clear. You can see the destination tile I had selected for a move out of the fog, but MARS is totally obscured.

I don't expect this to be easy to look in to given the lack of reproducibility, but I am hoping others can add notes here if they experience this bug.

badfog.png

 

Updated to indicate in thread title that the issue persists in V15.1.

Share this post


Link to post
Share on other sites

Yep the Maps still have Problems like this. Have this too. If it dosen´t make an CTD or something else ignore it after the Bug Report and test on. That´s the only Suggestion I can give to you, because I do the same.

That and other medium to light Map-Bugs will fixed step by step like the Devs announced. The oterh possibility is to wait another 6 Month for such in an big Step. Only for Map-Fixings waiting 6 more Month the Devs wouldn´t risk.

Edited by Alienkiller

Share this post


Link to post
Share on other sites
18 hours ago, Moonfire said:

I was in a ground mission for a UFO I had shot down when the fog of war stopped clearing for the soldiers I was moving around. There wasn't any obvious reason for this, and the issue cleared up when I saved and reloaded. I haven't been able to reproduce this and it doesn't seem to have been preserved in a save file, but I did grab a screenshot where I had moved MARS into a fogged area that didn't clear. You can see the destination tile I had selected for a move out of the fog, but MARS is totally obscured.

I don't expect this to be easy to look in to given the lack of reproducibility, but I am hoping others can add notes here if they experience this bug.

Thanks. Yeah, if a save game doesn't work to reproduce it then we're going to have problems tracking it down. In future, if anyone encounters the issue then please post in this thread with the following info:

  • The log files from the game (instructions on how to find them here), as that might tell us what triggered the issue.
  • A description of what happened immediately before the problem happened.

Hopefully then we might be able to reproduce it at our end.

Share this post


Link to post
Share on other sites

Update: Happened again in V15. Same fix, save and reload. Still unable to identify anything unusual or specific that happened before I noticed it again.

Share this post


Link to post
Share on other sites
3 hours ago, Moonfire said:

Update: Happened again in V15. Same fix, save and reload. Still unable to identify anything unusual or specific that happened before I noticed it again.

Yup, happened to me once too when I was testing the game. If you see it again can you post up the logs and also the save game and the save game from the end of the previous turn.

I've not yet worked out whether the effect kicks in from the start of turn or not. If it does then just getting the save from the end of previous turn should allow us to reproduce and fix it.

Share this post


Link to post
Share on other sites

Got one! This includes the auto-generated saves for the end of the previous turn, the start of the next turn, and the manual save after I noticed it was happening. I don't know if it stopped clearing the fog during the turn or at the start as I didn't move some of my soldiers much prior to noticing it. The file timestamp for the end and start of turns is 03:00, so that should help narrow it down a little. Also, expect possible irregularity at the end of the log as the game hung on exit to desktop.

auto_groundcombat_turn_4_start-24.json

auto_groundcombat_turn_3_end-23.json

user_bad_fog-2.json

output.log

Share this post


Link to post
Share on other sites
4 hours ago, Moonfire said:

Got one! This includes the auto-generated saves for the end of the previous turn, the start of the next turn, and the manual save after I noticed it was happening. I don't know if it stopped clearing the fog during the turn or at the start as I didn't move some of my soldiers much prior to noticing it. The file timestamp for the end and start of turns is 03:00, so that should help narrow it down a little. Also, expect possible irregularity at the end of the log as the game hung on exit to desktop.

auto_groundcombat_turn_4_start-24.json

auto_groundcombat_turn_3_end-23.json

user_bad_fog-2.json

output.log

Thanks. Annoyingly that save game doesn't allow reproduction of the issue either, so I guess we may have to go diving into the logs after all!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×