Jump to content

Search the Community

Showing results for tags 'bug'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News & Updates
    • Release Announcements
    • Development Updates
    • Off-Topic
  • Xenonauts-2
    • Xenonauts-2 General Discussion
    • Xenonauts-2 Bug Reports
    • Xenonauts-2 Features
  • Xenonauts: Strategic Planetary Defence Simulator
    • Xenonauts General Discussion
    • Xenonauts: Community Edition
    • Xenonauts Mods / Maps / Translations
    • Xenonauts Bug Reports / Troubleshooting

Categories

  • Complete Mods
  • Xenonauts: Community Edition

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Biography


Location


Interests


Occupation

Found 85 results

  1. After several hours of play I decided to quit, as I was getting the white triangle error and I didn't know the fix yet (I haven't had internet to verify the files there yet as it so happens), and when I did so the game crashed. Nothing happened for some time and when I tried to open the task manager it opened in the background. Sucks, but things happen, so I hard reset and when my computer turned back on the task manager opened. Little weird, but I started up the game again and played for a while, got the white triangles again, quit again, crash again, c+a+d again, task manager in background again, hard reset again, task manager opens on reset again. Wondering what might be up here, any information needed can be obtained and transmitted when I next gain internet for my laptop.
  2. Almost every combat mission I fight, I will encounter this bug. During the alien movement phase the foot step audio for an alien will start looping, and continue looping until that specific alien is killed or the mission ends. It is not limited to a specific alien type, and could be the sound of walking or running (if there's a difference) I cannot reliably reproduce this, or predict it. And there is nothing specific I've noticed that might be a cause or co-symptom. System: Win 7, SSD, running in Steam. Intel Xeon E3 cpu, Intel DZ77RE-75K mobo, 8GB DDR3 ram, EVGA GTX 970 video card, on-board motherboard soundcard using 5.1 speakers via 3 phone connector audio cables.
  3. Hi - first attempt at firing up the game, sent out a aircraft (Single interceptor) to investigate an anomaly. Gets there, runs out of fuel and asked it to return to base. It's now stuck and sort of twitches in place. I have attached the save file. Aircraft patrol stuck.json
  4. Shields, when equipped, are held in the wrongest possible orientation: Horizontally, bisecting the soldier. When fired on by an alien in their front arc, they protect the solder from taking damage by crashing the game. output.log recording_4.rec
  5. When you start a new game and click to place a put down a new base, the menu appears to name your base. Hit Cancel and the base is placed still, you get no radar circle either.
  6. The game will immediately crash to desktop when sorting soldiers by viewing the stats. To be more clear, I attached a screenshot to show the screen and what I'm clicking on that causes the crash. Here I have my mouse cursor on the STR stat, clicking on it will cause my game to crash. To reproduce: -Start new game -Go to barracks -Attempt to sort soldiers by clicking on any of the stats -Game crashes I've looked everywhere to see if there were any fixes. Any help will be appreciated greatly, thank you.
  7. During late game ground combat, especially assaulting larger UFOs (cruisers and up) and Fortresses, sometimes the Alien turn wouldn't end. The game does not crash. Steps to reproduce: - Begin combat - Play through as normal - At one point, alien turn wouldn't end. Mods used: Most of the X:CE bundle Armor Replacer Thanks guys. Game2 combat.sav
  8. I just found that the Buzzard Armor in my game doesn't fly. I assume it's an issue with a mod, but none of the mod threads have noted this problem. Looking through the game files, I'm not finding any issue with the jumpPack data string. Is there another way that the game denotes an armor as using flight? Edit: Playing around with the game files, I've found that my X:CE files are what dictate the properties of the armor, and it doesn't seem to change the flight parameter.
  9. When moving a second soldier to another (already moving) soldier's destination tile, the game will crash. recording_3.rec recording_4.rec
  10. so, not a big bug and you probably know about it, but like the title say alt+12 to report bugs didn't work for me so... if you are crouched, and give a move order that involves turning before moving, the TU remaining estimation does not count the TU of turning, so you usually end up 1 or 2 TUs short of what the estimate said. doesn't really seem to happen unless you are crouching though
  11. KnowledgeableAnt

    Bug: Burst fire animation

    I like the community edition better, but There is a very annoying bug that cuts the burst fire animation short. The soldier points his/her gun at the target, then the gun cuts back to the idle sprite and the bullets appear in thin air. It also does this with longer firing animations like sniper rifles. I've just beat the game on vanilla/ veteran difficulty, and would love to start a new modded play through. I tried disabling all other mods but the community edition itself, but the bug was still there so it must be a CE bug. Any help would be much appreciated.
  12. Hello, I'm playing Xenonauts Community Edition with almost no mods (only the base ones enabled automatically, plus Ambiant Sounds). I was recording live on Twitch and for a Youtube Let's play, so that's quite unfortunate if I can't deliver the content of endgame. The crash occurs during a mission with a Praetor. This is the only time I've had the game freeze like this, so it's probably either linked to the Praetor himself or Psy powers. The first the issue didn't occur at this point but 5 turns later while inside the ship. I reloaded this save, and never managed to go further : It always freezes at the end of this turn. I even tried to not move at all, but no luck. After about 8 retries, I gave up. You can download the save below. Thanks, all help is appreciated. Oz_encours.7z
  13. Every time I try to transfer soldiers from one base to another it doesn't seem to work. I select the soldiers that I would like to transfer, then I hit the transfer soldiers button and all of my soldiers that I selected then become unselected. When I select the base to transfer soldiers to nothing happens. Even after many (game) days the soldiers stay where they are... Am I doing something wrong?
  14. firebolt8900

    [CE 0.34] Main Menu is Broken

    I am trying to set up my game on a new machine (identical to the one I was playing on before with the exception of more RAM and a larger hard drive). The launcher works fine, but when I start the game I get several minutes of a black screen, and then the menu comes up as normal. The tabs all have their labels go white when I hover over them, but when I select an option, it does absolutely nothing. This includes the exit game option. I can easily Alt+tab out to manual close the game, but I can't play it as I cannot start a new campaign or load an old one. Steps I have tried so far: -Disable all mods but the 3 X:CE base mods -Uninstall and reinstall the game
  15. idefix

    Roof does not disappear

    Dear all, I have the problem that the roof of a big ufo does not disappear, see attached screenshot. Has here maybe anyone a solution for this? Doesn't make a difference what height I display using the scroll wheel of the mouse it just always displayes the roof of the ufo or is completely black. Thanks a lot.
  16. I have no idea how this has happened, but after relocating marauder-5 from one base to another it stacked in the air and then dissappeared. And one of the hangars in the destination base is unable to be destroyed, though it contains nothing (except this lost marauder). Is there anyway to destroy the hangar and the marauder? probably through the save file? version 1.59 stable
  17. I came back to the game yesterday and had alot of fun playing it, I noticed the bug many people have been discussing about the game momentairily freezing on Alien turns, however this was not of great concern. However upon returning to the game today I seem completely unable to even run the game. Even the main menu is highly unresponsive with the game frequently (according to my Windows task manager) becoming unresponsive, this has developed today and in its current state the game has become completely unplayable. To be clear I launched the game yesterday with no problems, the game launched, there was no problems in the menu and no problems in game (other than the frame skips on alien turns) and now today the game has become completely unresponsive. Any help you could offer would be greatly appreciated, I tried to search for a solution but to no avail. Edit: I am able to reach the main menu and occasionally after a bit of patience I can reach the campaign map after loading a game but the game frequently falls unreposnsive (being unresponsive around 95% of the time with the game poping back to life for a brief moment before freezing again).
  18. Hello again, I spotted a staircase that I wasn't able to use with my soldiers... when I clicked upstairs it would show the pathing green squares but the soldier would just stop at the base of it. I don't have any mods installed, am using the latest Steam stable release. I've attached the save I made there. bug.sav bug.sav
  19. Picked up Xenonauts again after a few months break and it now crashes almost constantly while I'm playing. It crashes occasionally when switching through the base options. It crashes occasionally when I try to change my solider's gear. It also sometimes crashes when starting a ground combat phase. In particular it seems to always crash when I try to view the garages of my bases and it also crashes when I try to move soldiers from their positions within the dropships. It feels very similar to the crashes reported in the Beta version ( http://steamcommunity.com/app/223830/discussions/0/540743213188167919/ ) in that it's very difficult to predict them. The crashes also continued after re-installing the game just a few days ago, so I'm at a bit of a loose end about it. Also, there appears to be a bug in my game where every single soldier in my base is apparently "unassigned" but all of the dropships have soldiers in them. This means that I can't actually assign enough soldiers to fill each dropship AND that when I look at the loadout screen there can actually be duplicates of my troops in the ship.
  20. I can't scroll to reach the bottom-most options in the Sub-map Editor, It cuts off at the options for "Command Room" and "Target Point" I find this irritating because I'm trying to make new props for some new buildings in my Building and Salaries Overhaul Mod (and maybe improve the Command Center to be a more accurate depiction. Additional Information: I'm using the smallest resolution size for the Sub-Map Editor.
  21. I have seen a couple of times that shots from Machine Guns/Scatter Laser/etc. can go through walls, and even suppress people and aliens on the other side of walls. http://images.akamai.steamusercontent.com/ugc/710784131785989295/D4A69B590FE2D062CB7829D43EBD09AAA5837F30/ Guy with scatter laser near the door to the right shoots the Ceasan - damaging and suppressing both the alien and my specialist on the other side of a wall. http://steamcommunity.com/sharedfiles/filedetails/?id=401005607 The selected machine gunner shot and killed the alien near the wall, suppressing the unit to the right, on the other side of the fence. In both instances, the walls were undamaged, but the shells and their effects went right through. Unfortunately I don't have saved positions for either of these events, closest ones were several turns away. But I think it should be pretty easy to reproduce (I've seen it 4-5 times during my 35+ hour time with the game).
  22. Okay I *think* it's 1.09 - whatever the current auto-updated steam version is right now basically, I got a little confused during the whole reversion/update process. First bug - * I have the alien base upgrade and obviously upon getting this the cosmetic appearance of the workshop/lab/barracks/storeroom changed accordingly to represent the quantum/nanotech stuff. At some point (possibly between updates) upon loading my game back up all background art for the facilities has reverted to the "tier" below (cosmetic change - slightly technologically upgraded, minor things - but not quantum/nanotech level as it should be). My base management screen still displays the correct top-down graphic for these facilities but all of the background art splashes for research/manufacture/troops/stores are now all incorrect - seemingly permanently - a purely cosmetic issue but an annoying one nonetheless, I wanna enjoy the look and feel of my advanced facilities and all that Edit - Screenshots added in here for clarification (hidden to prevent huge post): Notes: * I would have skipped the "tier" below because I acquired base upgrade before the things required for the minor costmetic-only upgrade that happens between the two. * I'm 95% sure I acquired the research for the minor cosmetic upgrade after getting base upgrade, which may have something to do with it. Although I'm pretty sure the "cosmetic downgrade" didn't occur until after re-loading my save file (after a week or so wait). Second bug - Upon completing missions there is missing text like so: I've always put this down to me playing on a low resolution (1024x768 -can't go any higher sadly) - but it has been this way since the earliest release version that I have played so I thought I may as well point it out in case it had been missed? Sorry if it's a repeat. A Steam Thing - No idea if this is just my PC or whatever but when I attempt to launch xenonauts from steam the launcher sometimes refuses to appear despite task manager telling me that xenonauts.exe is in fact running - the way I currently get around this is by killing the process and re-trying until it decides to appear. I don't *think* it's a waiting issue because I've given it a good minute or so before for it to pop up. Sorry if any of these are known issues, I'm not a forum regular or anything, just thought I'd mention these instead of being lazy and waiting for somebody else with the same issue to do it Edit: Oh and - Using WinXP (yeah...) and obviously the Steam version of Xenonauts (stable branch).
  23. If firstly research Plasma explosoves not alenium then warheads not changing on crafts automaticly. Need change research.xml about like this Researches.PlasmaExplosives 160 Weaponary Researches.AlienReactor(AND)Researches.AleniumExplosives Researches.FusionExplosives 240 Weaponary Researches.AlienFusionReactor(AND)Researches.PlasmaExplosives
  24. ver 1.09 While in ground combat, my characters (wearing predator armor) sometimes have trouble reloading their plasma castor - the work-around is to have the character drop the plasma caster, have another character pick it up and reload it; plenty of time units available
  25. Hello, so here's the deal: I have killed every single Xeno on the map. I know this because now it's turn 50 or something, I've checked every corner of the map with my men. No aliens anywhere. Also, I don't know if this feature is fully implemented yet - since I never surpass 20 turns in a battle - but I've been waiting for that air recon for ages with no dice at all. When I pack up and leave, it says I got 23/24 of all the aliens. Also no civies survived. I did not use stun gas so I'm sure I killed all. I didn't lose any of my men. I would also appreciate a way to save me from that inevitable fail nuke when I pack up and leave by the way... Thanks.
×