Jump to content
llunak

X:CE 0.32 Release Candidate

Recommended Posts

Guest

Also: Mogadishu Terror Attack results in a completely black map!

Share this post


Link to post
Share on other sites
Also: Mogadishu Terror Attack results in a completely black map!

Did this happen with a mission around dawn/dusk. I had what might have been the same issue with (what should have been) a dawn mission where the map was entirely black aside from some random bits of terrain that decided to reveal correctly but I didn't want to report it without having more data/being sure it wasn't a map-related issue.

Share this post


Link to post
Share on other sites
Still crashing, I'm afraid. Alien base, during alien turn (psionic attacks) or when shooting aliens. Pretty much the same as before. :(

I'm so sorry llunak, it appears I made a stupid mistake. The new .exe works fine. :)

Share this post


Link to post
Share on other sites
Guest

In this save game, a Sebilian has endless TUs and kills all of us. As I press End turn the Sebilian runs up and fires its gun untill everybody is dead. Like 6 times. I have none of the XC:E mods enabled.

Try to load it up and press End turn to see.

https://www.dropbox.com/s/umai6i0ie0r0ynk/Quicksave.sav?dl=0

Somehow it is related to the teleporters. Can't figure out how. But when I manage to get through a portal that is stuck, my unit suddenly have endless TUs. Somehow that can also happen to the aliens.

If I save, exit the game. Disable all mods. Reload I can sometimes cure it.

Other times it happens with mods installed. Then I disable all the standard RC2 mods. And it works again. Not sure how to repeat it 100%.

Edited by pistolhamster

Share this post


Link to post
Share on other sites
Soldier 'Killed' Dialog:

"<Soldier> has been critically wounded and entered a catatonic state."

Soldier Knocked Out Dialog:

"<Soldier> has been incapacitated and is now unconscious."

Soldier was deadly wounded. - as good as it gets :P

Share this post


Link to post
Share on other sites
In this save game, a Sebilian has endless TUs and kills all of us. As I press End turn the Sebilian runs up and fires its gun untill everybody is dead. Like 6 times. I have none of the XC:E mods enabled.

In the save the Sebillian already has 1000TU, so I have no way to find out how it happened. I would need an endturnautosave from before the problem occurs.

Share this post


Link to post
Share on other sites
Guest

Hi, I have installed RC3 by unzipping it into the Xenonauts folder and overwriting all content.

When I play (with all standardmods included and activated) I have experienced two crashes.

The latest crash is from a Landed UFO mission in an arctic tileset. After my first round I click End turn and I crash, having killed 1 alien.

The below message is the Windows crash dialog, not sure if I can get more on this.

Problem signature:

Problem Event Name: APPCRASH

Application Name: Xenonauts.exe

Application Version: 0.0.0.0

Application Timestamp: 54f5a179

Fault Module Name: Xenonauts.exe

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 54f5a179

Exception Code: c0000005

Exception Offset: 0014b7c1

OS Version: 6.3.9600.2.0.0.256.48

Locale ID: 1030

Additional Information 1: 5861

Additional Information 2: 5861822e1919d7c014bbb064c64908b2

Additional Information 3: 84a0

Additional Information 4: 84a09ea102a12ee665c500221db8c9d6

Share this post


Link to post
Share on other sites
Guest

Here you go:

https://www.dropbox.com/s/g0keqqemlz3wtjt/Quicksave-rc3crash.sav?dl=0

In the save game I move my troops and click End turn, it then crashes during Alien movement when playing on RC3.

Any other information that would help apart from system specs?

All standard mods enabled btw.

Edit: here is the same savegame a few turns later. The teleporter is broken so nobody can use it not aliens, not humans. I think this somehow relates to the Endless TU phenomenon I have encountered.

To "Fix it" I

1) Save game as proper save (not quick save) and Quit

2) Disable ALL mods in Mod Launcher (keeping ofc X:CE Balance, X:CE Settings, X:CE Base Mod)

3) Load the game up and enter the portal - its "stuck still."

4) Hit Quicksave.

5) Exit the game. Load it again with mods disabled still. Seems to work. SOme times but not always.

1 Turn where I notice the Teleporters are "stuck" and not working.

https://www.dropbox.com/s/qw90umaeop9yl3t/teleporterstuck2.sav?dl=0

2 Turn where I have turned off mods and loaded it up again, didnt fix it.

https://www.dropbox.com/s/v44jus7cka44q87/teleporterstuck4.sav?dl=0

3 Last turn where I have still turned off mods. Didnt fix it. But when I then load turn 2 (above) it is fixed and I have also endless TU when stepping on the teleporter.

https://www.dropbox.com/s/umai6i0ie0r0ynk/Quicksave.sav?dl=0

Edited by pistolhamster

Share this post


Link to post
Share on other sites

I still cannot reproduce any problem. The first save works just fine if I end the turn, and soldier can use both of the teleports with the second save. Since you mention that turning off mods makes a difference, maybe one of the mods you use is somehow causing it.

Share this post


Link to post
Share on other sites
Guest

Darn this is so strange. I have in these two savegames a situation where an alien (red guy in the middle of the room that is revealed when you turn a xenonaut). He has endless TUs which I know because his reaction fire just keeps going.

I have included save from that turn and previous turn.

I suspect the Teleporters are involved, since it only happens on missions where there are teleporters involved.

From a XC RC 2 with no mods enabled.

Before:

https://www.dropbox.com/s/g4o2y19dg8243pr/Before-tu.sav?dl=0

After

https://www.dropbox.com/s/owt5f5g3pyy3w9e/After-tu.sav?dl=0

Anyone want to help?

Download the save and load the After save.

Turn Xeno #5 around and attack the alien in the middle of the room at distance to see if you can enable his reaction fire. If he misses he will keep shooting for ever.

Share this post


Link to post
Share on other sites

I've tried having a look at the save. The alien you've highlighted definitely has excess TUs (in the GC Editor they're set to 1000).

However, there's not a lot more I can do with it at the moment as my version of the GC editor is buggy (from RC2). Testing in the non-editor build, I tried running the game for several turns but haven't been able to reproduce the issue. But if there's specific conditions which cause it there's a very good chance I didn't explicate them exactly.

On the subject of teleporters, though, I'm not sure how this would be the case here. The problematic unit isn't anywhere near a teleporter and doesn't appear to have excess TUs in the 'before' save you provided (so doesn't seem like it's been caused by teleporting earlier in the mission). It could be related to Wraiths teleporting, mind.

(By the way, I note in your post you wrote RC2. Was that a mistake and did you actually mean RC3?)

Share this post


Link to post
Share on other sites

I still cannot reproduce either. I'll add some extra checks so that TUs don't get these weird values, but that's about all I can do.

Share this post


Link to post
Share on other sites
Guest

Hi Illunak,

I think I am getting very close to figuring out why:

The cost of moving through the teleporter seems to be the issue. In my current game it costs about 40 TUs to cross the teleporter for each unit. But for some reason I cannot figure out, in some game sessions - and it varies if you load / save and reload without quitting the app - the cost of crossing the Teleporter seeems to fluctuate. This means in a particular game the cost is negative so much that my Unit - after having crossed - ends up with a ridiculous positive value of 1289324234 or somethin - essentially endless for the game's purpose.

The cost is apparantly shared by aliens and xenonauts, which means I sometimes see aliens with endless TU''s because they crossed the teleporter and had the value added to their TUs rather than subtracted.

In other games I never meet any aliens below decks on the alien ships with multiple floors. They are essentially stuck above because the cost of crossing the Teleporter is too high for their TUs.

Perhaps the values used in the formulate for calculating the cost to cross a teleporter square should be set to a fixed cost of X tus to see if that changes this behaviour? At least I suspect modifying how TU and teleporters are calculated would give more light to.

And funny is it varies from load to load of the same saved game!

I am running with only base X:CE mods that is required for the game (Settings ,balance, base) - should I turn off more or is this ok?

Edited by pistolhamster

Share this post


Link to post
Share on other sites

I got something in my mind about this endless turn situvation.. Someone said here an alien with unlimited TU fired 6+ shots and killed everybody.. but even an enemy unit got 100k TU, shooting TU's are % of the units turn. So the tons of TU unit should fire only limited fires regardless its TU.. so this is confusing.

Share this post


Link to post
Share on other sites
I got something in my mind about this endless turn situvation.. Someone said here an alien with unlimited TU fired 6+ shots and killed everybody.. but even an enemy unit got 100k TU, shooting TU's are % of the units turn. So the tons of TU unit should fire only limited fires regardless its TU.. so this is confusing.

The % shooting cost is taken from the unit's max TU score rather than their current. When you add TUs to a unit (e.g. when using the GC editor) it only increases current and not maximum, therefore the costs for shooting stay the same.

Share this post


Link to post
Share on other sites
The cost of moving through the teleporter seems to be the issue. In my current game it costs about 40 TUs to cross the teleporter for each unit. But for some reason I cannot figure out, in some game sessions - and it varies if you load / save and reload without quitting the app - the cost of crossing the Teleporter seeems to fluctuate.

Well, in that case you have a broken install that never sets TeleportUseAP in any config.xml . The cost is 8TU with xcebalance and 0TU with just base X:CE.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×