Jump to content

Milestone 3.5.0 Released! (Experimental)

Recommended Posts

This update is also only accessible by switching to our Experimental branches (instructions on how to do so here) - although note they have slower load times and worse performance than normal builds due to the extra logging they contain!

This hotfix addresses a few bugs we introduced in our last Experimental hotfix, as well as several additional bugs in the current public builds.


  • Fixed a bug where players were unable to hire scientists / engineers in some circumstances.
  • Fixed a bug where unassigned soldiers could display the incorrect armour name in the armour dropdown - e.g. be visually equipped with the Warden Armour, but the dropdown would read Tactical Armour.
  • Fixed soldiers being unable to crouch if another soldier was already moving.
  • Updated the code so that if you press the Crouch button when a soldier is moving, they will try to crouch at the end of their move. We've now capped this to one attempted crouch action, so pressing the button multiple times will no longer waste TU by queueing up crouch / uncrouch actions.
  • Fixed being unable to disable the air combat Afterburners / Retreat buttons during the initial deployment phase.
  • Fixed movement / turning not being interrupted when sighting an enemy if you were doing it as part of a grenade throw action (it worked fine when firing a weapon).
  • Fixed the visual flicker that would occur after finishing an air combat battle as the cities briefly appeared on the map and then hid themselves.
  • Fixed the tactical UI displaying a white soldier portrait outline if you have no soldier selected (usually occurs if the selected soldier is killed).
  • Fixed the Cleaner HQ mission sometimes not revealing immediately when you reach 100% on the progress tracker.
  • Fixed the soldier minitabs at the top of the tactical UI not showing the number of USB sticks on the tile of an unconscious soldier (like it does for dead soldiers).
  • Fixed a Boreal log pile that had a graphical glitch with one of the logs.

Attempted Bugfixes:

These bugs appear hardware linked and none of the dev team can reproduce them, so we're relying on affected users to let us know whether the fixes worked!

  • Attempted a fix for the issue some people are experiencing where the exterior walls of the office on the Cleaner Data Raid missions display black.
  • Attempted a fix for the entire screen going black when a unit fires a weapon in the tactical combat (this is the bug that could be fixed by disabling the "camera shake" setting).
  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...