Jump to content
tkzv

[1.65L, ground combat] Game crashes, troubles with saves

Recommended Posts

Version 1.65 for Linux, bought via Humble Bundle. Launcher says "Release 1.65L Stable (3 March 2016)", when starting it writes to console "INFO: Xenonauts, version 1.0sdl."

1. During ground combat the game occasionally crashes. As it progresses, the crashes seem to become more frequent. At the start I could play for days without trouble, but as I reached December 1979, I get several crashes during each mission.

2. The game now often crashes when I save a game. This results in a corrupted save. See the attached "Quicksave.sav". The correct file from the same mission is "UFO-86-2.sav".

3. When I try to load such corrupted save, the game hangs and stops responding to anything short of SIGKILL. I understand it's impossible to load the broken save, but the game could at least handle it more gracefully.

4. (unrelated to the above) Quick load doesn't work. When I press the quick load key, nothing happens. Manually loading the "QUICKSAVE" game works fine.

5. (unrelated to the above) During the alien base mission the dead enemy commander is represented by the same sprite as the living one. See the attached "base 1-3.sav"

Quicksave.sav

UFO-86-2.sav

base-1-3.sav

 

Update: added another broken Quicksave.sav and the corresponding log "2018-03-10 - OutputLog.txt"

Quicksave.sav

2018-03-10 - OutputLog.txt

 

Update 2: Same crashes with regular saves.

Edited by tkzv

Share this post


Link to post
Share on other sites

I also had a similar problem. The launcher says "Xenonauts: Community Edition 0.34.3 (23 Jul 2017)". I play on Windows, purchased through steam. Every time I attempt to load the alien base mission, the game crashes. I started out with the vanilla game, but after reading several suggestions online, I upgraded to the community edition. The game continues to crash while trying to load the alien base mission. Other suggestions I've tried included making sure the dropship wasn't empty [it wasn't], loading the game on windowed mode with a lower resolution, and loading the game with the "Xenonauts_gc_editor" executable. None of these suggestions worked.

Help!!!

JM1.sav

Edited by miahkins

Share this post


Link to post
Share on other sites
10 hours ago, miahkins said:

I also had a similar problem. Every time I attempt to load the alien base mission, the game crashes. I started out with the vanilla game, but after reading several suggestions online, I upgraded to the community edition. The game continues to crash while trying to load the alien base mission. Other suggestions I've tried included making sure the dropship wasn't empty [it wasn't], loading the game on windowed mode with a lower resolution, and loading the game with the "Xenonauts_gc_editor" executable. None of these suggestions worked.

Help!!!

JM1.sav

XCE doesnt work for Linux. Use WINE or a similar program.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×