Jump to content

Puciek

Members
  • Posts

    124
  • Joined

  • Last visited

  • Days Won

    3

Posts posted by Puciek

  1. As old as the original ufo games are, and xenonauts proudly following suit, it is usually smart to over-pack your soldiers, and then on first turn drop the excess eq into a neat stockpile at the dropship. Stuff like more ammo, replacement shields, grenades, stun weaponry, what have you - just to give you more versatility while in the field. And fair is fair, well placed explosive by the aliens means that much more gear is then destroyed.

    The process is tedious to do in every fight, so why not expand the dropship with some storage that you can put gear into at base (within some sensible weight/grid limits)? Same result, so no balance changes, just without all the annoyances that go with the current solution of over-packing and dropping. If this feels like maybe OP, introducing full load weight limits into dropship would be one way to fix it, although if the locker is op, so is over packing, but that now quietly happens, anyway.

    • Like 2
    • Thanks 1
  2. I wiped out my gamex/xeno2 folder just to make sure there are no lasting issues.

     

    Then i start xeno2, I can hear music going, and it opens in a full screen as per default settings. I change those, and can see that display.json changes accordingly:

     

    {
        "Fullscreen"false,
        "Display"0,
        "DisplayWidth"1920,
        "DisplayHeight"1200,
        "DisplayRefreshRate"100,
        "Vsync"1,
        "TargetFrameRate"60,
        "SSAO"false,
        "SSAA"0,
        "GraphicsQuality"5,
        "Brightness"0.0,
        "Contrast"0.0,
        "ContrastRedChannel"0.5,
        "ContrastGreenChannel"0.5,
        "ContrastBlueChannel"0.5,
        "Gamma"1.0,
        "CameraShake"true
    }

    Now I exit the game, the file is still as seen here, and then mooment I turn it on again, boom, it's reset to defaults, same with audio.json etc. Seems it just resets them at every start, instead of once. And I can reproduce it every time,
     

    {
        "Fullscreen"true,
        "Display"0,
        "DisplayWidth"3440,
        "DisplayHeight"1440,
        "DisplayRefreshRate"100,
        "Vsync"1,
        "TargetFrameRate"60,
        "SSAO"false,
        "SSAA"0,
        "GraphicsQuality"5,
        "Brightness"0.0,
        "Contrast"0.0,
        "ContrastRedChannel"0.5,
        "ContrastGreenChannel"0.5,
        "ContrastBlueChannel"0.5,
        "Gamma"1.0,
        "CameraShake"true
    }
  3. image.png.29b2dabc2e95968f3956c5607d92afde.png

     

    Because of a CTD bug (described in separate post) that I kept trying to reproduce my entire autosave from that base assault is just 5 slots of end of that turn, thus forcing me to replay the mission to try to correct the bug. Ideally it should simply replace the previous turn 5 end save then turn 5 ends for the 2nd+ time, thus preserving previous turn saves.

  4. On 2/19/2021 at 12:15 AM, Chris said:

    Thanks, and to you too maxm222. There's a whole bunch of issues to do with the shroud at the moment so I'm a bit reluctant to look into this one right now because I think it may get fixed when we look into the other ones. So probably one for us to check out once V18 is out.

    No problem, thanks for letting me know! I won't report similar ones then, until at least few patches come in.

     

    As for why imgur: copy/pasting images here in the past makes them tiny, or at least did in the past. Imgur keeps them raw and full :D

     

     

  5. Picutre says it better than I possibly can with words: https://i.imgur.com/LlQBid7.png

     

    And once I moved closer, the ship has rendered and corpses went away: https://i.imgur.com/wEgSNJs.png

     

    There is also a lesser issue that after loading the game from save instead of glowsticks I am getting the purple texture as you can see. Obviously attaching save with corpses visible and textures gone, move towards them to unearth the ship.

     

    If you need some other logs to track it down, let me know!

    user_corpses-3.json

  6. 6 hours ago, Chris said:

    Weird, I can do that even with your save loaded in a 21:9 resolution. Is there anything unusual about your input setup (or any other unusual hardware)? Or do you just have a standard keyboard + mouse?

    Ok I've unplugged everything but mouse and keyboard (there is also VR plugged in but it's off, and to unplug this one would be way too much hassle) and sadly still no ability to scroll. I've checked with dxdiag, no other inputs left besides just the m+k. Tried windowed, full screen, full screen windowed etc, no luck with any of those.

  7. 5 minutes ago, Chris said:

    Weird, I can do that even with your save loaded in a 21:9 resolution. Is there anything unusual about your input setup (or any other unusual hardware)? Or do you just have a standard keyboard + mouse?

    I have whole cockpit worth of flight sim hardware plugged in so maybe it's getting input confused with something like the pedals or the yoke, or the controllers, or the MFDs... I will try to unplug it later on and see if that helps, though that is a lot of usb hubs to go through, so bear with me, i'll ping you when I had a chance to test it without them (later in today).

     

    Either way, keys for scrolling will solve it for sure, and seems like more natural idea, and maybe some indication on the screen that it's scrollable?

  8. 3 minutes ago, Chris said:

    Thanks. Unfortunately I can't reproduce this, and without the logs it's tricky to know what's going on. There's another minor crash we're planning to patch out in a mini-hotfix that doesn't break save games that might fix this though, so maybe if we're lucky this won't reoccur...

    A shame. Any idea why my game would not be producing logs? I tried reinstalling, removing my games/xenonauts 2 etc, no luck.

  9. I tossed a stun grenade on a wound reaper and a frag grenade (it landed 2 squares north-west in current perspective from where stun grenade went off), and the moment it exploded the game crashed to desktop. Sadly I do not have the logfile, my game doesn't make them for some reason, but I did manage to snap the error with a screenshot: ffRas1Y.png

     

    Also attaching closes in time save

    auto_groundcombat_turn_10_start-163.json

  10. Screenshots in chronological order: https://imgur.com/a/THgKai5

     

    In first screenshot before throw, in second after throwing one stun grenade, and then after lobbing the 2nd stun grenade (you can see them disappearing from the access inventory on right hand side), and the cloud they create seems to be of a smoke not stun grenade. Not sure if it's just visual or actual game confusion. Attaching save too, soldier used to try: number 1.

    auto_groundcombat_turn_9_start-161.json

  11. I just intercepted destroyer with 2 escorts and decided to try something else by fitting all 3 interceptor with torpedoes and setting them all right onto the destroyer. To my surprise as soon as the torps hit the destroyer and it went down, the air combat has abruptly ended with victory (even though the two alein escorts were still alive and mostly untouched) and the escorts just dissapeared of the map. That doesn't seem right, as this means as long as I can get the torps out on target, the escorts do not matter much, unlike if they were to continue chasing my planes down.

     

    Attached save just before interception.

    auto_strategy_before_intercept-44.json

  12. 6 minutes ago, Chris said:

    That does sound very weird, yeah. Unlike X1 the boundaries of the map are relative to the UFO, though - so if the aircraft and the UFO are travelling at the same speed and in the same direction then the aircraft will never escape. But an Angel is quicker than a Destroyer so I'm not sure why it woudn't have been able to escape ... I think maybe retreating planes fly more slowly perhaps.

    Just to be clear though, you're saying that you can't see the entire battlefield by scrolling up? You should be able to do that. Maybe the air combat doesn't handle 21:9 resolutions very well.

    Since that I've tried scrolling with wasd and directional keys, holding mouse, nothing happens. Anything else you would want me to try?

     

    Re retreat speed, they do seem sluggish on retreat, though can the low fuel be cause of it?

×
×
  • Create New...