Jump to content
thedjstu

[v18.3 HF2 Geoscape]Still no laser ammo on research

Recommended Posts

Just to clarify, this is a new game. And I did another new game after just to check to see if it fixed itself, it didn't.

Share this post


Link to post
Share on other sites

Can verify this, and fixed it in my own game. Its because the research topic "Laser Weaponry" unlocks 'Item.Lasercell' rather than 'ammo.laser.lasercell'. Switching them in the researches.xml set laser ammo to infinite when I researched Laser tech.

Share this post


Link to post
Share on other sites
Can verify this, and fixed it in my own game. Its because the research topic "Laser Weaponry" unlocks 'Item.Lasercell' rather than 'ammo.laser.lasercell'. Switching them in the researches.xml set laser ammo to infinite when I researched Laser tech.

As ammo for plasma and T4 weapons was changed to unlimited too, this fix is needed for them as well, i think.

Has not actually checked in game, but corresponding changes in "researches.xml" is identical, so.

Share this post


Link to post
Share on other sites

any chance you guys can share the corrected file with those of us who aren't as savvy with modifying the game's xml files ?

Share this post


Link to post
Share on other sites

If someone has already moved pas laser and plasma research the clips have to be enabled manually. One way to do this would be to modify the researches.xml file.

1. Simply paste following rows into the "When finished" column of the xml next to a research you are currently doing in the game:

UnlockItem("ammo.laser.lasercell");

UnlockItem("ammo.plasma.plasmacell");

2. Don't forget to use ALT+ENTER to go to the next row while staying in the cell

3. Now wait until the research is done and the clips will become available

There is also probably a more direct way to enable them without having to wait for the next research to end, but am gonna hit the hay for now ;)

Share this post


Link to post
Share on other sites

Also, stealth update. My fix now brings back the Stun Rocket when Stun weapons are researched. Have fun!

Share this post


Link to post
Share on other sites

Thank you Sathra, you rock, this is now also in the bugtracker :)

Share this post


Link to post
Share on other sites

Better update HF2 then. Thanks for pointing out the errors. I've cleaned up items.xml to remove the confusion duplicates now too, so hopefully it won't happen again.

Share this post


Link to post
Share on other sites

Despite having this update I still do not have the laser cells available, either for research or manufacture.

I researched all laser weapons, but have no research or manufacture for Laser cells.

I even loaded a savegame from before I researched laser weapons and still dont have them.

Only way I could get them was to set the laser cells to unlimited in the items.XML file

Edited by Bansheedragon

Share this post


Link to post
Share on other sites
If someone has already moved pas laser and plasma research the clips have to be enabled manually. One way to do this would be to modify the researches.xml file.

1. Simply paste following rows

[...]

Don't forget to use ALT+ENTER to go to the next row while staying in the cell

I hope classical old-style plain-text editor (unaware of 'cells', 'rows' and 'alt-enter') will not spoil this XML?

(I prefer not to install extra MS products when I can manage without)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×