Jump to content
Chris

Xenonauts-2 Closed Beta Build V1 Released!

Recommended Posts

First Tactical Mission (Probe) I had issues with stun grenade: 1. Could not switch grenades had to move all other grenades to backpack to select gas.(Had same issue with taser rounds.) 2.Gas animation disappeared when rotating the map became impossible to tell which tiles where affected.(didn't get a screen cap) 3. Knocked out Psyon Engineer remained as active enemy (indirect sight) mission would not end, I used C4 on the tile where unit was and blast killed it ending the round.(also no screen cap) 4. Stunned Xenonauts appear in base storage as recovered loot, as did captured Engineer even though he died.

922557099_Xenonauts230_11_20181_16_40PM.thumb.png.f72016658c9017b9ae08ec6a6fffda73.png

Geoscape: Skyranger wont land when on slowest speed it keeps keeps going back and forth, does land on faster speeds.

Armory: Laser Rifle only has 1 Laser Battery rather than an infinite source.

Xenonauts_2_30_11_2018_1_20_49_PM.thumb.png.ee390e9f39f38775b2af81cb0220cf68.pngXenonauts_2_30_11_2018_1_20_59_PM.thumb.png.caece357d7173404406f691ffb163999.png

Second Tactical Mission (Scout): CTD after loading screen.

Aerial Combat: Condor damaged in first Aerial Combat was repaired but red damage indicator reappeared in second Aerial Combat even though health 100%. (sorry don't have a screen cap)

On a side note I do have to say how much I enjoyed aliens creeping up my blind spots in the jungle biome, it felt like predator...

 

Share this post


Link to post
Share on other sites

Have tested it too. Airfight is working fine, same in the Base for Research and Production. Haven´t seen there a crash or whatever.

Haven´t had a Ground Mission yet, so I can´t say anything to this.

Will test the Inventory System for Soldiers in the next Fix / Update and get hopfully an Ground Fight too.

Share this post


Link to post
Share on other sites
On 11/29/2018 at 2:23 PM, LordAntony said:

Constant CTDT after combat mission, when my Falcon-1 returns home. Save attached.

 

fgdg.json

Today's update fix it. And load folder too.

Share this post


Link to post
Share on other sites

Loaded up the game, no issues

Built some bases, renamed soldiers and generally screwed around, no issues

Detected, shot down a few UFO, no issues

Finally had a UFO crash on some land, looking forward to some close encounters, tilt rotor reaches target, start loading screen

This is where the game crashes, loads up the bottom corner of the map (see below) then goes to black screen and game crashes

Encounter Load Error.png

Share this post


Link to post
Share on other sites

Do not have screen shot for that as yet:

Game crashed to desktop 3 times while starting combat in the UFO.  Windows 10 pro 64bit

Today I started 3 games, different base locations, adding a second hanger with jet for the first 2, first one had a second radar installed

First game - 1 UFO's appeared as I launched my interceptors it would turn around and exit my range, 10 UFO's appeared, could not intercept.  I waited and watch 5 incursions, UFO would fly in a few kilometers then turn around and exit screen.  Last 2 games NO UFO's ever appeared from start to your end of game.

Also noted that when switching to the padded armor, the mouse pointer would be off to the upper left of window, yet when put over the armor slot, it would show the drop, putting the place holder for the armor over it would not accept the change.    Did not get the screen shot of that, will try again later.

 

LoadtheOrig

 

Edited by LoadtheOrig
Added issues

Share this post


Link to post
Share on other sites
On 12/4/2018 at 9:38 PM, Grey_Matter said:

Loaded up the game, no issues

Built some bases, renamed soldiers and generally screwed around, no issues

Detected, shot down a few UFO, no issues

Finally had a UFO crash on some land, looking forward to some close encounters, tilt rotor reaches target, start loading screen

This is where the game crashes, loads up the bottom corner of the map (see below) then goes to black screen and game crashes

 

Issue now fixed after recent update, serving out lead salads to alien house guests

Edited by Grey_Matter
Forgot to mention update

Share this post


Link to post
Share on other sites
4 hours ago, LordAntony said:

Constant CTD on January, 8. Save attached. The latest patch (December, 6) installed.

222.json

Thanks. Please could you post in the new threads for the new builds or in the dedicated bug forums though? It's hard to tell which reports are for which builds otherwise because we've released a lot of builds in a short space of time.

So the crash at the end of day 7 was something I thought we had fixed in the latest build. Can you just confirm you're starting a new game in the new version, rather than playing an old save from an older version? I don't think the update will fix old save games.

Share this post


Link to post
Share on other sites
12 minutes ago, Chris said:

Thanks. Please could you post in the new threads for the new builds or in the dedicated bug forums though? It's hard to tell which reports are for which builds otherwise because we've released a lot of builds in a short space of time.

So the crash at the end of day 7 was something I thought we had fixed in the latest build. Can you just confirm you're starting a new game in the new version, rather than playing an old save from an older version? I don't think the update will fix old save games.

Yes, it was old save. I'll try a new game. If I will have any trouble - let you now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×