Jump to content
Chris

Xenonauts-2 Closed Beta Build V1 Released!

Recommended Posts

Found that if you blow yourself up with C4, the game instantly crashes.

Tried to load into an autosave made after the UFO was shot down, sending a team to the crash site crashes the game as well. (only after the C4 crash)

Can't make any saves in mission but can on the geoscape.

Also, I can't load into saves from the main menu, I have to start a new game before going to the pause menu to load them.

Share this post


Link to post
Share on other sites

Just 1 minor bug noticed so far. Time Units not sorting correctly in the soldiers screen. The other values seem to sort correctly.

Share this post


Link to post
Share on other sites

I've played the game twice so far today and encountered a couple of different CTD's. 

On my first play through everything was working well. I was able to complete the default research, then the research on laser rifles, and then I was able to start constructing laser rifles. I managed to get two completed before I had my first UFO encounter. I successfully shot down the UFO but when I attempted to send the Skyranger to the UFO I did this by selecting "Launch Aircraft" on the Geoscape rather than clicking on the crash site and selecting "Begin Mission" from the Armoury screen. The steps I followed were as follows:

  1. Select "Launch Aircraft"
  2. Select the crashed UFO as the target
  3. Select the Skyranger as the interceptor to use
  4. Select "Launch Interceptors"

The game immediately CTDs and this seems to be consistently reproducible in a different save game.

Once I was able to launch the ground combat mission, I found that I could not save the game within the mission. It looks as though the save is happening, but no save game is created. I tried this multiple times but to no avail. No issues saving in the Geoscape, but I couldn't save when in Ground Combat.

Once in ground combat, I had a soldier that was injured by alien fire. I moved another soldier over and attempted to use the medkit to heal them. Instead of healing the soldier I seemed to end up stunning the soldier. Unfortunately I didn't take a screen shot, but while the initial text seemed to indicate a heal, at some point it changed to stun. I could have clicked twice, but in X1 if you healed twice the second time it didn't do anything.

My second CTD came at the end of the ground combat. I was able to successfully kill all the aliens but as soon as I killed the final alien on the probe I encountered a CTD - likely when I would have received the mission success screen. I've no save file due to the problems mentioned previously, but I've attached the output.log and recording file from that second CTD - couldn't find anything from the first one. 

I'll keep testing but please let me know if you need any additional information.

output.log

recording_6.rec

Share this post


Link to post
Share on other sites

1. You can type a way too long name for your base.

2. With a 21:9 display (3440x1440) confirmation windows (for example when firing personnel) does not open centered but too much to the left.

3. CTD when intercepted an UFO with Skyranger-1 and clicked on "Commence attack".

 

Share this post


Link to post
Share on other sites

Graphics and performance-wise, no issues.  All the issues I did see have already been reported...

- crash after ground mission, Ranger heading back to base (may be tied to multiple projects in queue)

- during ground fight, alien was killed but he stayed upright, death animation didn't play

Share this post


Link to post
Share on other sites

CTD on Geoscape when Falcon1 returns to base after shooting down first UFO.  I was able to investigate the crash site with a ground team, complete the tactical mission and had the skyranger return to base, so it looks like it was something with the interceptor.

Share this post


Link to post
Share on other sites

Hello Commanders !

Another round :)

Geoscape / Base Management :

Base naming : the Return key does not validate the input.

Renaming soldier : you can overflow the UI with long names. (Cf screen)
1498989831_Renamingsoldiers.thumb.png.62fca0981948301e3dd6e7606733765c.png

 

Sometimes an item armory tooltip will stay on others screens, could not find how to reproduce consistently, something with the sprite edges maybe ? Cf screen

 

Tooltip.thumb.png.e9e2ee4a350876410f11493238fcfd4c.png

 

Launch aircraft consistently produce a CTD if you select a crash site as a target and launch Skyranger.

Exemple save : 

Lauch aircraft target crash CTD.rar

 

Tactical Layer : 

Is there a way to lock a soldier ?  To not having him/her in the list when tabbing between soldiers. Big QoL.

 

Other CTDs : 

Cannot go into the second combat mission (probe crash), modified some soldiers loadouts. 

Logs and save Second mission CTD loadout modified.rar

 

Others

Performance / Graphisms and general feeling of the tactical layer is amazing ! 

 

Share this post


Link to post
Share on other sites

Hi,

I have multi monitor setup, main is 2560x1440. Found the following interesting points, was not able to reach to combat zone (yet). :)

1. These buttons not working at all

buttonnotwork.thumb.jpg.28285a8434b1c6d5f3dbcf39a1e0953c.jpg

2. Renaming bug

1198965067_nameissue.jpg.a7d94159ad37a56c8cf75d511f3ca80b.jpg

3. Weapon misplaced

weaponmisplaced.jpg.ff4d3ce68f08a3138a5cf187bab167d3.jpg

4. Engineering project time (probably you didn't worked on this yet)

engineeringtimes.jpg.58cf349f3c50b4754520280a5665010b.jpg

5. And finally the whole map died - I was able to get into sub-menus and to the proper map screen clicking twice, but the time changer buttons stopped reacting.

worldmapdies.thumb.jpg.e3cd41f4a6e104dd63a27386890c0ca0.jpg

 

Share this post


Link to post
Share on other sites

Alright, great, thanks for all the feedback. We're planning on releasing a hotfix today if possible so I'm going to skim this thread for the crashes and critical issues we might be able to fix, and then I'm going to go through everything people have reported and record it in our issue tracker so we can fix up as much as possible for the next big build.

  • Like 1

Share this post


Link to post
Share on other sites

First of all congratulation on the beta launch GHI, i'm happy for you guys.

So i tried one battle today and everything went pretty smoothly except for something one of my dudes got shot for 35 damage of 37 health by a plasma rifle, after that, i attempted to heal said soldier and i discovered that i couldn't neither heal him nor select the soldier entirely, he literally disappeared from the UI, the soldier model was still in the scenario, also bleeding wounds might not inflict DOT damage, but i'm not so sure about that, given that once a soldiers gets shot and leaves a small puddle of blood, i can't say if it's a simple sign that the soldier got damage or is indeed a bleeding wound.

Still, i'm quite happy with how the game plays and looks i feel like it's going to the right direction.

Share this post


Link to post
Share on other sites

Combat Mission.

Floor texture of the alien ship bug. When I move/rotate the camera, cells randomly disappear.

Can't shoot/throw a grenade through an open door in any direction, but right in front of the soldier.

Saves.

I saved game (combat mission or global map) successfully and quit. When I tried to load it from the menu - folder was empty, BUT "continue" button was enabled and load my game correctly. Save's name is FGDC. And yes, it is visible from Save menu.

Menu.

Anywhere in the game: ESC -> Quit game ->Main menu. Actually, I am quitting the game, but not returning to the main menu.

 

My Specs:

Windows 10 x64 (build 1809);

Intel i7-7700HQ;

16 Gb RAM;

Nvidia Geforce 1070 (driver 417.01).

Untitled.thumb.png.60445d2b3f027bd5a827f6f18412ee21.png

Edited by LordAntony

Share this post


Link to post
Share on other sites

User Interface issues

Keyboard mapping

Hello. I just started testing this build, shot my first UFO and went to the first map. I'm somewhat unable to play it as i can't remap the navigation keys to my AZERTY keyboard. I changed the keys in the launcher but it didn't seem to have an impact in-game, and didn't include rotation keys anyway ... seemed like a placeholder settings from the underlying Unity engine. Now, working around this by using only the mouse to navigate and rotate with Q (located at A) is somewhat possible, but very annoying and definitely not something that would be tolerated in a finished game. I suppose it's something that has to be added, but as a non-qwerty user i consider that an essential feature. Even if you don't have an UI for remapping available, simply exposing those in a config file would definitely help during the beta.

Armory

I noticed the same issues reported above. Besides those issues i find the armory clunky and unintuitive to use

  • I think it's very annoying that we can't see a list of soldiers with their stats in the armory screen and/or we can't change a soldier "class" in the recruits screen (where those stats are visible). I don't wan't a slow moving assault but if i want to select the soldiers with the most TUs as assaults, i have to either look at the recruits screen, remember who has the most and change their class in the armory or look at each soldier individually in the armory screen and try to remember the stats of the previous soldiers. Even simply being able to go from the recruits list to the armory with a double-click on a soldier's name would be a nice improvement.
  • Drag-and-drop is good for mobile interface or when there is multiple places to put something. A weapon that can only be put in the primary slot shouldn't require drag-and-drop. Being able to equip/unequip using double-clicks would save a lot of time for important things (such as actually fighting aliens). Belt-slot items should also automatically go there when double-clicked if there is some empty space. It's only when putting something in the backpack that drag-and-drop is justified.

Graphics Glitch

Graphics quality set to simple (3/5) i got some ugly artefacts around the edge water bodies in the snow landscape as you can see in this picture. My video card is a GeForce GTX 750 Ti.

Shadows were very blocky but maybe it's normal at that quality setting.

Saving

In order to see how the water would look at higher quality i saved (or thought i did) in-mission under the name "Beta1" and exited. When i tried to load the save i didn't see any and it's nowhere to be found in my saved game folders either. There is an auto-save from before the mission started (and i can load it using the "continue" button) but the manual save i attempted to create failed without any error message.

Strategic map bug

Reloading the last auto-save i encountered a fun strategic bug. I sent the skyranger to the mission site again and switched to fastest speed. The skyranger almost teleported from the main base to the mission site and then jumped back-and-forth above the mission site while the time was flowing until it was out of fuel and then returned to base. I could reproduce it again after exiting and restating the game so i won't try to play further in case you want to have a look at that save. The mission site is approximately at the same latitude (longitude?? the horizontal level on the map, can't remember which one it is) as the base.

Tactical missions

Not sure whether it's a planned feature that haven't been implemented but it seems like a "core" feature to me. The lack of LoS indicator in the tactical missions is really annoying compared to X1 where you had some sort of "shading" over areas not covered by the vision cone of your soldiers.

X2-WaterArtefact.jpg

Share this post


Link to post
Share on other sites
1 hour ago, Trance said:

First of all congratulation on the beta launch GHI, i'm happy for you guys.

So i tried one battle today and everything went pretty smoothly except for something one of my dudes got shot for 35 damage of 37 health by a plasma rifle, after that, i attempted to heal said soldier and i discovered that i couldn't neither heal him nor select the soldier entirely, he literally disappeared from the UI, the soldier model was still in the scenario, also bleeding wounds might not inflict DOT damage, but i'm not so sure about that, given that once a soldiers gets shot and leaves a small puddle of blood, i can't say if it's a simple sign that the soldier got damage or is indeed a bleeding wound.

Still, i'm quite happy with how the game plays and looks i feel like it's going to the right direction.

Thanks. Not sure why the soldier died but there's a known bug where units that die from overwatch fire (and maybe bleeding I guess) don't play their death animation and just remain standing, which I'm guessing is what happened here.

53 minutes ago, LordAntony said:

Combat Mission.

Floor texture of the alien ship bug. When I move/rotate the camera, cells randomly disappear.

Can't shoot/throw a grenade through an open door in any direction, but right in front of the soldier.

Saves.

I saved game (combat mission or global map) successfully and quit. When I tried to load it from the menu - folder was empty, BUT "continue" button was enabled and load my game correctly. Save's name is FGDC. And yes, it is visible from Save menu.

Menu.

Anywhere in the game: ESC -> Quit game ->Main menu. Actually, I am quitting the game, but not returning to the main menu.

Thanks. Yeah, the Load Game panel will be fixed in the upcoming hotfix, as will the crash that occurs when you try to exit to Main Menu. The UFO floor mixing with the ground is an issue we'll be looking into for the next big build, we're not really sure what's happening there.

21 minutes ago, Lord Yanaek said:

<snip>

Thanks, lots for me to read through. A number of those are issues we'll be fixing in the next big build and the Load Game menu will be fixed in our next hotfix. The LoS indicator can be accessed by pressing the eye button on the UI, that's something we need to look over again and then possibly enable by default.

I'll log up the keybinding stuff to be done in the medium term, and also the armory issues mostly result from us not having had the time to finish implementing all the systems yet. There's still a number more quality-of-life improvements we need to introduce on that screen (although it's definitely better than it was six weeks ago!)

Share this post


Link to post
Share on other sites

Thanks Chris for very quick feedback but have a breath, the Beta is only just starting :D

So i decided to have a look at that LoS indicator (i didn't even notice that eye icon), made a 7zip backup of the previous state in case you need the save for the Skyranger bug and sent the skyranger at a slower speed. This time i got a CtD each time when the mission is about to start. Here is the relevant part of the log. Full log (7zipped) is attached.

2018-11-29 12:41:24,515 [FATAL] (D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\XenonautsMain.cs:511) 
[INITIAL CRASH]
System.NullReferenceException: Object reference not set to an instance of an object
  at Xenonauts.Strategy.Systems.BaseStoresSystem.GetItems () [0x00029] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\Strategy\Systems\Base\BaseStoresSystem.cs:240 
  at Xenonauts.Strategy.Systems.BaseStoresSystem.GetUsedCapacity () [0x00009] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\Strategy\Systems\Base\BaseStoresSystem.cs:94 
  at Xenonauts.Strategy.UI.BaseStoresBuyElement.SetCapacityText () [0x00015] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\Strategy\UI\Elements\BaseStoresBuyElement.cs:148 
  at Xenonauts.Strategy.UI.BaseStoresBuyElement.SetBottomBar () [0x00024] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\Strategy\UI\Elements\BaseStoresBuyElement.cs:138 
  at Xenonauts.Strategy.UI.BaseStoresBuyElement.<OnCreate>m__A (Artitas.Entity item) [0x00001] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\Strategy\UI\Elements\BaseStoresBuyElement.cs:85 
  at Artitas.Family+<EntityRemove>c__AnonStorey1F.<>m__0 (Artitas.Family family, Artitas.Entity entity) [0x00007] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\Family.cs:831 
  at (wrapper delegate-invoke) System.Action`2<Artitas.Family, Artitas.Entity>:invoke_void__this___Family_Entity (Artitas.Family,Artitas.Entity)
  at Artitas.Family.RemoveEntity (Int32 entityID, Int32 componentID, IComponent previous, IComponent next) [0x00097] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\Family.cs:507 
  at Artitas.Managers.FamilyManager.UpdateComposition (Int32 entityID, Int32 componentID, IComponent prevComp, IComponent newComp, Boolean added) [0x00145] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\Managers\FamilyManager.cs:312 
  at Artitas.World.MutateComponentOnEntity (Int32 entityID, Int32 componentID, IComponent previousC, IComponent nextC, Boolean added) [0x000da] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\World.cs:322 
  at Artitas.World.HandleDelayedMutations () [0x000c5] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\World.cs:280 
  at Artitas.World.DeleteEntityImmediately (Int32 entityID) [0x0003a] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\World.cs:184 
  at Artitas.World.DeleteEntity (Int32 entityID) [0x00061] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\World.cs:172 
  at Artitas.Entity.Delete () [0x0000d] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\Entity.cs:177 
  at Xenonauts.Strategy.StrategyScreen.DisposeStrategyWorld () [0x00129] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\Strategy\StrategyScreen.cs:249 
  at Xenonauts.Strategy.StrategyScreen.OnExit () [0x00024] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\Strategy\StrategyScreen.cs:208 
  at Common.Screens.DataStructures.ManagedScreen`2[Xenonauts.GameScreens,Common.Screens.DataStructures.IScreenParameters].Exit () [0x00026] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\Screen\DataStructures\ManagedScreen.cs:216 
  at Common.Screens.ScreenManager`1+<CreateMoveToAnimation>c__AnonStorey2[Xenonauts.GameScreens].<>m__1 (UniversalTweenEngine.Timeline t) [0x00012] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\Screen\ScreenManager.cs:334 
  at UniversalTweenEngine.BaseTween`1+<OnEnd>c__AnonStorey2[UniversalTweenEngine.Timeline].<>m__0 (Events event, UniversalTweenEngine.Timeline source) [0x00007] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\TweenEngine\Code\BaseTween.cs:203 
  at UniversalTweenEngine.BaseTween`1[T].CallEventHandlers (Events type) [0x00044] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\TweenEngine\Code\BaseTween.cs:437 
  at UniversalTweenEngine.BaseTween`1[T].UpdateStep () [0x00288] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\TweenEngine\Code\BaseTween.cs:590 
  at UniversalTweenEngine.BaseTween`1[T].Update (Single delta) [0x00054] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\TweenEngine\Code\BaseTween.cs:477 
  at UniversalTweenEngine.Timeline.OnUpdate (Int32 step, Int32 lastStep, Boolean isIterationStep, Single delta) [0x00076] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\TweenEngine\Code\Timeline.cs:270 
  at UniversalTweenEngine.BaseTween`1[T].UpdateStep () [0x00281] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\TweenEngine\Code\BaseTween.cs:589 
  at UniversalTweenEngine.BaseTween`1[T].Update (Single delta) [0x00054] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\TweenEngine\Code\BaseTween.cs:477 
  at UniversalTweenEngine.TweenManager.Update (Single delta) [0x00090] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\TweenEngine\Code\TweenManager.cs:114 
  at Common.Screens.ScreenManager`1[Xenonauts.GameScreens].Update (Single deltaTime) [0x000d1] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\Screen\ScreenManager.cs:146 
  at Xenonauts.XenonautsMain.Update () [0x00066] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\XenonautsMain.cs:436 

 

output.7z

Share this post


Link to post
Share on other sites

Alright, hotfix V1.1 is out. You can see the changelog here: https://www.goldhawkinteractive.com/forums/index.php?/topic/19680-xenonauts-2-closed-beta-build-v11-released/

This fixes most of the crashes that have been reported in V1, and there's a few other non-crash fixes too. Please post in that thread if you encounter any problems with that build. Unless we've introduced any new critical bugs with the hotfix it'll be at least a week until the next update - so I think I'm going to go and catch up some sleep! :D

Share this post


Link to post
Share on other sites

Hi i just had an update, is there a changelog somewhere.

 

1 minute ago, Chris said:

Alright, hotfix V1.1 is out. You can see the changelog here: https://www.goldhawkinteractive.com/forums/index.php?/topic/19680-xenonauts-2-closed-beta-build-v11-released/

This fixes most of the crashes that have been reported in V1, and there's a few other non-crash fixes too. Please post in that thread if you encounter any problems with that build. Unless we've introduced any new critical bugs with the hotfix it'll be at least a week until the next update - so I think I'm going to go and catch up some sleep! :D

LOL Beat me by a second.

Edited by Yandros

Share this post


Link to post
Share on other sites

Cant shoot the guy, no reason why that I can see but the weird clipping happened as soon as I went in and now I cant shoot either of them

clip.png

Doh! Better make that can't do anything after my guy died in the ship except move the rest about, no other function works, cant even end turn.

Edited by Kaiphus_Kain

Share this post


Link to post
Share on other sites

Last build (1.1) helped much with text font problems and with CTD too. Nice. Still cannot save in ground combat. When i do save, no new save visible if i try to load when in ground combat.

First picture. Graphic glitch maybe? Have guy with that shield, when crouch and shield equiped, it looks this wierd.

Second picture, some problem with ladder. When ladder seems from inside / wrong side, i can get on roof. If ladder look normal and is placed from outside, its impossible to get on the roof.

 

Shieldbug.png

zebrik.png

Edited by Cerun

Share this post


Link to post
Share on other sites

I encountered a CTD when my soldier with the shield got hit with the rifle alien's first shot. The shot was done through a hay bale at the soldier from two tiles away.  Though many of the other bugs graphically and otherwise that I have seen here I have not experienced. Sadly that is likely all the testing I can do today. 

The research for the placeholder laser weaponry worked fine.
Re positioning soldiers in the lander worked fine. 
No issues re-equipping soldiers. 
During mission before crash tested out AR, Grenade launcher, pistol, sniper rifle, LMG. Overwatch shots. Everything else seemed to work fine. 

 

If it helps for your reference. 
Windows 10 (64bit)
24 GB ram
i7-6700k not overclocked at 4.0 ghz
Nvidia 2080
 

Share this post


Link to post
Share on other sites

Chris,

Maybe there should be a Bug Reporting thread for this and move all the current reports to it as well?   The title doesn't seem to match the purpose of the thread anymore.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×