Jump to content
Chris

Xenonauts-2 Closed Beta Build V1 Released!

Recommended Posts

11 minutes ago, ColKadlik said:

1. I can save game and it shows in the Load Game screen while I'm in game on the Geoscape, but when I get to the Main menu. there are no Games to Load in the Load Game screen, but Continue button is functioal and loads my last saved game. 

2. When I Quit a game from the Geoscape, that I previously saved exited and continued from the Main menu, and select Quit to Main menu option the game crashes.

Xenonauts 2 Save game Screen 01.bmp

Xenonauts 2 Save game Screen 02.bmp

Yeah I just noticed those two things myself. The "Load Game" screen you get from the in-game Esc menu still works, but the Main Menu one is broken. And quitting to the Main Menu does indeed close the whole game instead.

Share this post


Link to post
Share on other sites

Found a bug regarding the placement of Icons on the Geoscape.

This is what it should look like:
Geoscape_Correct.thumb.PNG.16d35ea8137043055ae92212213c69a8.PNG

Drag the Geoscape a bit to the right, the main base disappears from Greenland

Geoscape_Bugged_1.thumb.PNG.7fd66b4c454cced80e9f5792ee365882.PNG

A bit more to the right, main base reappears but in northern Canada

Geoscape_Bugged_2.thumb.PNG.ad4771d131020aed62e6a9a3c51f43de.PNG

A bit more to the right.
The Main Base Icon is now in Scandanavia. 
The Base, Planes, and Crash Site Icons are now in Central Asia instead of near Egypt.
Some radar visible (barely) on right side of screen. (Expected)
No radar visible on left side of screen. (Unexpected)

Geoscape_Bugged_3.thumb.PNG.57c06574e3604ffd75b5827b09f87a97.PNG

A bit more to the right.
Main base is now back to correct location. 
Base, Planes, and Crash Site Icons are still in the same place in central Asia.
More radar visible on right side of screen (Expected)
Still no radar visible on left side of screen (Unexpected)

Geoscape_Bugged_4.thumb.PNG.d0d6bddd77c71846b85d5002aa92ed94.PNG

A bit more to the right.
Base, Planes, and Crash Site Icons wrapped off screen to left. (Unexpected)

Geoscape_Bugged_5.thumb.PNG.ba8c5ea185d4bac33bf6a554fc51fe98.PNG

The behavior is the same regardless of the direction scrolled.

 

Share this post


Link to post
Share on other sites
6 minutes ago, Chris said:

Not sure I'm going to have any easy way to test the steering wheel comptability :)

Regarding the cursor / item being out of sync, you mean when you start dragging it the item isn't appearing on your cursor? We had that issue a couple of days ago but I thought we'd fixed it; it's tied to screen resolution. If that's the problem I'll ask the coders to check the fix again.

More an FYI unplug it if its weird, I normally do so its just chance I had it connected, also yes exactly that on the cursor.

 

Oh, forgot to say in the other post THANK YOU for letting me move my whole team without snapping back to the person I just told to move!! Always hated it doing that in the old game.

Edited by Kaiphus_Kain

Share this post


Link to post
Share on other sites

Possibly related to tolkien_fan_95's issue.  Map icons disappear from the right 20% or so of the map and appear off the lefthand side, visible here as part of my asia-pacific base's name tag sneaking in on the left, with its radar circle in full view on the right:

20181128175624_1.thumb.jpg.128ea839c438a16ef3ba825e3358393c.jpg

 

Also, seem to be getting dubious line blocking in combat in some situations, for example targets standing on the edge of raised terrain:20181128180714_1.thumb.jpg.e16786d4787fcc2ad20b4e41151ba5d3.jpg

 

While other times when I would expect some blocking have none, such as behind this bush:20181128180740_1.thumb.jpg.c3f240c7d4a3edbdb36a9ff9a3d69da6.jpg

Share this post


Link to post
Share on other sites

The CTD I reported a few minutes ago is repeatable from the auto-save but I'm not sure where to find the file.  Checked in AppData, etc., but can't seem to track it down.  Anybody know where to find it?  I figured repeatables are never a bad thing to send in.

Share this post


Link to post
Share on other sites

Ok, more "fun" with the Continued previosly saved game.

1. When I Continue from Main menu previously saved game, and then on the Geoscape try to Load any of my othe previously saved games the game crashes.

2. Also Continued game where I've before saving done nothing more then just placed a base and after continuation put time flow on the max level and ignored everything. Then on the begining of the 8 day, when the "Thanks for playing" screen shoul show, the game crashes instead.

Share this post


Link to post
Share on other sites

Just had a CTD on a ground mission, full team in the medium scout UFO, crashed as one of my units died to one of the little creeper grey guys, aliens turn.

 

2018-11-28 21:50:20,259 [FATAL] (D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\XenonautsMain.cs:511) 
[INITIAL CRASH]
System.ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
  at System.Collections.Generic.List`1[Common.Board.Slot].get_Item (Int32 index) [0x00024] in /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Collections.Generic/List.cs:635 
  at Common.Board.Board.GetSlot (Int32 addressID) [0x00008] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\Board\DataStructures\Board.cs:286 
  at Common.Board.Board.GetSlot (Address address) [0x00009] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\Board\DataStructures\Board.cs:276 
  at Common.Board.Board.StepOn (Artitas.Entity entity, IEnumerable`1 footprint, IEnumerable`1 natures) [0x00018] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\Board\DataStructures\Board.cs:227 
  at Common.Components.BoardComponent.StepOn (Artitas.Entity entity, IEnumerable`1 footprint, IEnumerable`1 natures) [0x0000a] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\Components\BoardComponent.cs:21 
  at Common.Board.Systems.GenericBoardSystem.<OnInitialize>m__3 (Artitas.Entity entity, Common.Components.FootprintComponent footprint) [0x0000d] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\Board\Systems\GenericBoardSystem.cs:61 
  at Artitas.Family+<ComponentAdd>c__AnonStorey12`1[Common.Components.FootprintComponent].<>m__0 (Artitas.Family family, Artitas.Entity entity, Int32 cID, IComponent rem, IComponent add) [0x00022] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\Family.cs:697 
  at (wrapper delegate-invoke) System.Action`5<Artitas.Family, Artitas.Entity, int, Artitas.IComponent, Artitas.IComponent>:invoke_void__this___Family_Entity_int_IComponent_IComponent (Artitas.Family,Artitas.Entity,int,Artitas.IComponent,Artitas.IComponent)
  at (wrapper delegate-invoke) System.Action`5<Artitas.Family, Artitas.Entity, int, Artitas.IComponent, Artitas.IComponent>:invoke_void__this___Family_Entity_int_IComponent_IComponent (Artitas.Family,Artitas.Entity,int,Artitas.IComponent,Artitas.IComponent)
  at (wrapper delegate-invoke) System.Action`5<Artitas.Family, Artitas.Entity, int, Artitas.IComponent, Artitas.IComponent>:invoke_void__this___Family_Entity_int_IComponent_IComponent (Artitas.Family,Artitas.Entity,int,Artitas.IComponent,Artitas.IComponent)
  at Artitas.Family.UpdateEntity (Int32 entityID, Int32 componentID, IComponent previous, IComponent next) [0x00082] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\Family.cs:487 
  at Artitas.Managers.FamilyManager.UpdateComposition (Int32 entityID, Int32 componentID, IComponent prevComp, IComponent newComp, Boolean added) [0x00044] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\Managers\FamilyManager.cs:276 
  at Artitas.World.MutateComponentOnEntity (Int32 entityID, Int32 componentID, IComponent previousC, IComponent nextC, Boolean added) [0x000b6] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\World.cs:319 
  at Artitas.World.HandleDelayedMutations () [0x000c5] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\World.cs:280 
  at Artitas.World.MutateComponentOnEntity (Int32 entityID, Int32 componentID, IComponent previousC, IComponent nextC, Boolean added) [0x000e8] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\World.cs:326 
  at Artitas.World.HandleDelayedMutations () [0x000c5] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\World.cs:280 
  at Artitas.World.MutateComponentOnEntity (Int32 entityID, Int32 componentID, IComponent previousC, IComponent nextC, Boolean added) [0x000e8] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\World.cs:326 
  at Artitas.GlobalEntity.AddPosition (Vector3 value) [0x0005c] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Generated\Entity\GlobalEntity\PositionGlobalEntityDSL.cs:73 
  at Xenonauts.GroundCombat.Systems.GCInventorySystem+<AutoSort>c__AnonStorey1.<>m__0 (Artitas.Entity item) [0x00072] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\GroundCombat\Systems\GCInventorySystem.cs:179 
  at Xenonauts.GroundCombat.Systems.GCInventorySystem.AutoSort (IEnumerable`1 items, Artitas.Entity targetSlot, Boolean allowSlotExpansion) [0x00058] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\GroundCombat\Systems\GCInventorySystem.cs:192 
  at Xenonauts.GroundCombat.Systems.GCInventorySystem.CreateContainerWithItemsForDroppedActor (IPostCombatantStatusReport r) [0x000cb] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\GroundCombat\Systems\GCInventorySystem.cs:138 
  at (wrapper delegate-invoke) System.Action`2<Xenonauts.GroundCombat.Systems.GCInventorySystem, Xenonauts.GroundCombat.Events.IPostCombatantStatusReport>:invoke_void__this___GCInventorySystem_IPostCombatantStatusReport (Xenonauts.GroundCombat.Systems.GCInventorySystem,Xenonauts.GroundCombat.Events.IPostCombatantStatusReport)
  at Artitas.Core.Utils.ExpressionUtil+<ActionFromMethodInfoFactory>c__AnonStorey1`4[Artitas.Systems.EventSystem,Xenonauts.GroundCombat.Events.IPostCombatantStatusReport,Xenonauts.GroundCombat.Systems.GCInventorySystem,Artitas.IEvent].<>m__0 (Artitas.Systems.EventSystem target, IEvent param) [0x0001c] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\Utils\ExpressionUtil.cs:151 
  at Artitas.Systems.EventSystem.HandleSubscribers (IEvent event) [0x00050] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\Systems\EventSystem.cs:49 
  at Artitas.Systems.EventSystem.Handle (IEvent event) [0x00003] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\Systems\EventSystem.cs:26 
  at Artitas.DefaultProcessStrategy.Process (IEvent event) [0x001c6] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\World.cs:808 
  at Artitas.DefaultProcessStrategy.Process () [0x00024] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\World.cs:751 
  at Artitas.World.Process () [0x00007] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Artitas\Artitas.Core\Code\World.cs:621 
  at Common.Screens.DataStructures.WorldManagedScreen`2[Xenonauts.GameScreens,Common.Screens.DataStructures.IScreenParameters].Update (Single deltaTime) [0x00032] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\Screen\DataStructures\WorldManagedScreen.cs:49 
  at Common.Screens.ScreenManager`1[Xenonauts.GameScreens].Update (Single deltaTime) [0x000f3] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Libraries\Common\Code\Screen\ScreenManager.cs:149 
  at Xenonauts.XenonautsMain.Update () [0x00066] in D:\Jenkins\workspace\X2 (Build)\release-0.33.0\Assets\Code\Screens\XenonautsMain.cs:436 
 

 

Edited by Kaiphus_Kain

Share this post


Link to post
Share on other sites
5 minutes ago, tolkien_fan_95 said:

Found a bug regarding the placement of Icons on the Geoscape.

Thanks. Yeah, things get pretty funky when you wrap a map section that contains icons. It's already on our to-do list but it's quite a big task; we probably won't get it done for the next build but it'll get fixed at some point in the beta.

 

2 minutes ago, Vithigar said:

Also, seem to be getting dubious line blocking in combat in some situations, for example targets standing on the edge of raised terrain.

While other times when I would expect some blocking have none, such as behind this bush:

Yup, those two are unrelated issues but they are issues. The first one is because it's quite difficult to know when a cliff edge should be cover and when it shouldn't, so it's always counted as cover - for example, if you were targetting the two aliens further back in the screenshot you'd probably expect it to count as intervening cover. It's kinda tricky to know where the draw the line ... but I'm sure we'll figure something out eventually.

Share this post


Link to post
Share on other sites
2 minutes ago, Psitticine said:

The CTD I reported a few minutes ago is repeatable from the auto-save but I'm not sure where to find the file.  Checked in AppData, etc., but can't seem to track it down.  Anybody know where to find it?  I figured repeatables are never a bad thing to send in.

It's under My Documents >> My Games.

There's definitely a crash in the game that occurs if you complete a project and there's another project in the queue after it; if that's the cause of the bug for you then don't worry - pretty sure we'll hotfix that one tomorrow!

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Chris said:

It's under My Documents >> My Games.

There's definitely a crash in the game that occurs if you complete a project and there's another project in the queue after it; if that's the cause of the bug for you then don't worry - pretty sure we'll hotfix that one tomorrow!

Aw man, I already lost so much sleep the past few weeks :'-(

Kidding, we're glued to the issue tracker at the moment and patching what we can!

  • Like 1

Share this post


Link to post
Share on other sites

Second report :

Having a consistent CTD as soon as I try to lauch the skyranger on a shot down UFO.

Here is the save and log just before : to reproduce just launch aircraft => skyranger => select crash site.

 

CTD Skyranger SaveAndLog.7z

Edited by Yandros

Share this post


Link to post
Share on other sites
2 minutes ago, Vithigar said:

Crash in combat, just hit (maybe killed? CTD before I found out) last visible alien on the map.

Logs.7z

Got it in the issue tracker as well, looks to be a bug in the auto-dropping of items to the floor.

Share this post


Link to post
Share on other sites

Another consistent CTD when engaging a live UFO with the Skyranger.

(Yes I like to test edge cases :p )CTD Skyranger engage UFO SaveAndLog.7z

7 minutes ago, Gijs-Jan said:

Aw man, I already lost so much sleep the past few weeks :'-(

Kidding, we're glued to the issue tracker at the moment and patching what we can!

Keep up the good work ! 

As a fellow dev I have to go and empty my issue tracker now.

Have a nice day everyone.

Share this post


Link to post
Share on other sites

Small inconsistency in UI behaviour:

When viewing "Research complete" dialog, I can interact with any visible buttons without closing the dialog.  This dialog box is non-blocking.
When viewing "Recruitement report" dialog, I cannot interact with anything except the buttons in the dialog box.

This leads to a result that looks bad:Dialog_Box.thumb.PNG.9be04499210c0b44e02c3f964c9627f5.PNG

Steps to reproduce:
1. Click first message Icon --> Research report appears. -- Can interact with other visible UI
2. Click second message Icon --> Recruitment report appears -- Cannot interact with any UI other than three options on recruitement report.


I'm not sure whether I expect blocking or non-blocking dialog boxes, but I am sure that I expect them to be consistent. 


In both cases the timer continues to run.  I would expect the timer to pause while I read a report and to resume when I close the report.  

Share this post


Link to post
Share on other sites

I recorded a video and made it unlisted so only people clicking through this forum can access it.

My list of bugs in the first build (timestamps are also in the youtube video, so you can jump right to the bug there)

I have a 4K monitor so many of the geoscape visual bugs are likely caused by the high resolution

2:35 it is possible to cancel the first base, that is confusing and a newbie may not find the „build base“ button

3:00 „health bars“ of continents display elsewhere

4:05 without building the first base the „launch aircraft“ is active and the possibility to launch Skyranger appears

4:35 Africa base displays elsewhere on the geoscape

7:40 role change and equipping role gear does not work

8:00 can unequip a weapon by right clicking, but cannot equip a weapon by right clicking

8:05 when I grab a weapon the small image is show elsewhere

9:00 it is confusing that the armory and manage space in aircraft is in the same button

9:20 changing the time flow works by clicking the 1234 keys (not on numpad) but the change is not visually represented on the bottom of the screen by highlighting the corresponding arrows

12:10 it looks like a “main base” and the base that I built both exist. Skyranger is in the “main base”, falcon is in the new base.

13:00 the Skyranger and “main base” icons on the map are displayed elsewhere than the “source to target” line

14:00 Falcon and UFO are not displayed, probably again displayed elsewhere (off screen)

15:10 construction of living quarters take like 2 days instead of 5 days

16:00 (not native English speaker) maybe there should be “sell” instead of “sale”?

16:55 I have no idea how to control the air attack. (maybe some buttons off screen?)

17:40 the graphical representation of 0/100 is the same as 6/100. There should be something like “destroyed” displayed

17:50 Aerial battle result says “-0HP” instead of  “-100HP” when my plane was destroyed. I did not find a way to buy a new aircraft

18:15 minor graphical bug – highlighting the hangar only highlights the left half

23:50 minor graphical bug – number of dots top and down is not the same

26:35 graphical bug – straw over cart

26:55 graphical bug – black seam line

29:40 cannot see behind a building (there is no hint that E is used for rotating)

32:20 graphical bug – exploded hay

35:00 it looks like soldiers have a very long range for throwing (and throwing is very TU cheap)

35:30 saving on ground combat does not work

42:50 why did my soldier stop moving? peripheral vision of an alien? there was no “alien spotted” icon

45:05 my soldier appears on a tile twice with different postures

46:30 graphical bug – cabbage through floor

49:10 walls are destructible but door not?

53:45 mission with a Skyranger with only a few soldiers alive crashes the game

Share this post


Link to post
Share on other sites

I’m going to head to bed now because it’s been a long day, but the reports in this thread have been extremely useful so far and I’m sure any posts that follow will also be equally useful. Thanks to everyone that has taken the time to post their thoughts and experiences!

  • Like 1

Share this post


Link to post
Share on other sites

---
Alright, first run.
And a crash-to-desktop once I tried to begin my first Ground-Combat-Mission.

I'll keep it more simple and tell only the biggest "stabbing"-bug for now:

The Geospace-timer pausing is very random.

It's thankfully paused when player doesn't have "line-of-sight", like when viewing base-management-tabs and there is a menu-element obstructing the clock.
But most importantly the timer keeps going forward in the whole ESC-menu.

---

Oh, I suppose it's worth mentioning that you can't insert <SPACE> in the base-names;
another stabber-bug.

---

Anyways, here is also the output-log-file
( found at the bottom of this post );
as a reminder to others who might be unaware, this can be found via this place:

C:\Users\<user>\Documents\My Games\Xenonauts 2\Logs


Or as simplified on Windows 10:

This PC > Docuement > My Games > Xenonauts 2 > Logs

---
---
---

output.log

Edited by Pave

Share this post


Link to post
Share on other sites

UI bug: Launch Control Dialog Box


Partially repaired interceptor's health displayed to unnecessary precision.

Unnecessary_health_precision.thumb.PNG.2b5e31f5d4a0d5f9a1663d534de86169.PNG

 

Edited by tolkien_fan_95
Forgot to delete image

Share this post


Link to post
Share on other sites

OK, had a chance to catch up and I'm adding this as a separate note since my first one is back a page now and I'm not sure an edit would be spotted.  This is the save file for the repeatable crash upon arriving at a shot-down Scout.  I don't believe it is related to the queued project bug as my research queue was empty before sending the Skyranger off and remained so during the flight.

auto_save_0003.7z

Share this post


Link to post
Share on other sites

Hey guys,

Ran into a crash during my first mission.  I was moving a soldier into the ufo when an alien fired overwatch and the game crashed.   I had error reports enabled so hopefully you guys can get some useful info from that.

output.log

Edited by bazankow

Share this post


Link to post
Share on other sites

I got soft lock during an alien turn, had breached the ufo with C4 a couple turns prior and one of the aliens ran out of the ufo and stopped, the turn then would not finish. If I get it to happen again I'll record a video with shadowplay or something. I'd guess it'd be some pathing or AI error where the alien couldnt decide on who to shoot after it left the ufo.

 

I also noticed maybe a bug but I couldn't select smoke grenades from the grenade belt when there were frags still left, same with flashbangs. I might be just missing how it works or something but I tried left clicking (which just draws it), right clicking (does nothing), middle mouse clicking etc.

 

Another issue I noticed, left clicking the grenade quick access will trigger alien overwatch, not sure if this is intended or not. One thing that mustn't be intended is that this overwatch, if it hits or not, stops you from actually using the grenade

Share this post


Link to post
Share on other sites

First combat mission. Not sure if it's related to the bug in the auto-dropping of items to the floor mentioned earlier, but I doubt it since I don't believe I killed the alien to cause items to drop.

I threw a frag grenade onto an alien and it exploded (the location was a mix of fences and a staircase leading into a house. Not sure if the blast just had too many interactions with the environment as it caused a CTD after popping damage numbers on the alien.

output.log

Share this post


Link to post
Share on other sites
3 hours ago, Chris said:

Yup, those two are unrelated issues but they are issues. The first one is because it's quite difficult to know when a cliff edge should be cover and when it shouldn't, so it's always counted as cover - for example, if you were targetting the two aliens further back in the screenshot you'd probably expect it to count as intervening cover. It's kinda tricky to know where the draw the line ... but I'm sure we'll figure something out eventually.

I would actually not expect a 3' cliff to be cover no matter how far back from the edge the target was.  If the top of the cliff was above eye level, sure, but for a rise that looks like it's about hip-level? How would that make any sense? If the two other targets were at the bottom of the cliff on the far side, sure, but nowhere on top of that rise should be in cover.

Edited by Vithigar

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×