Jump to content
Coffee Potato

[X-Div V 99.45 - Geoscape] Save Explosion

Recommended Posts

(I attached the 3 surviving autosaves, hoping to get some idea of what's going on here from Mr Charon. )

Right Before: https://youtu.be/HbbYrd_qUm4

I was streaming my run of this earlier, nothing seemed out of the ordinary. When I went to save, it seemed to save just fine. At that point, I did my usual routine of going through squad management, and re-organizing things a bit better. At that point I went to save, and the game crashed. So, I reloaded it, and found my hard save deleted. At this point I went in and tried to do it again, figuring it was one of those rare bugs, redid my squad, made a new save, and crashed. At that point I tried to launch a mission with just that same party. I had figured maybe it was the planes in the air maybe messing with something, since I don't think that was a base game feature. One time, it launched, and it made a new auto save. Upon saving, it crashed again. I tried to repeat this process, and it crashed, but made a second, seemingly identical autosave?

At any rate, I hope this has an answer, I'm stumped. 





Share this post

Link to post
Share on other sites

@Coffee Potato

Yes - the game crashes everytime you try to make a save.

I can only assume it has something do with the fact that the base evacuation code is new, and the current save has something which it cant cope with. I assume it could be the soldier with 1 health at the end of the base attack, but frankly, this also happens in the vanilla game.


I can only ask @Solver to look into it and see if he can remove the thing which blocks the saving process.

Other than that having a save before the mission ends, and a save before the mission starts is your best bet.

Share this post

Link to post
Share on other sites

@Solver I just rechecked the Base Evacuation code, and saving seems to funtion when aircrafts are midflight after the aliens successfully take over a base, as well as after touching down in the new base. So everything seems to work.

Share this post

Link to post
Share on other sites

Also, the two identical autosaves were a test launch that didn't crash one time, and inexplicably duplicated itself when I tried to launch with an actually prepared group afterwards. Not sure if that helps.  

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now