Jump to content
Sign in to follow this  
Coffee Potato

[ X:CE 0.34.3] Half-Turn Breakage

Recommended Posts

[ X:CE 0.34.3] Half-Turn Crash

I was a UFO mission, ended my turn, one unit fired and plinked off of a window, another ran by a building, while the camera focused on a shadow and some movement. At this point it seemed to just be stuck. I left it for a few minutes, no menus would open. I exited the game, came back, and the same turn started progressing, with that same unit now firing through the window and killing my guy. Time travel shennanigans?

[ X:CE 0.34.3] C4 Glitch

I know this one's been around a minute, but I've had several times where I would place down a C4 pack, run away, only to have a completely different C4 pack on a completely different person explode 1-2 turns apart. This ended my strategy of "C4 Everything". For one example, I wasn't sure whether a base life support system needed to make a bigger kaboom in order to go down. So, I piled like 6 C4s on that mess. Two rooms away, two soldiers guarded a door with untold droves of terminators behind it. None of them had moved since starting this massive redecoration project. So the scout drops off her boxes of cookies and the group heads back to the evacuation square with the others. At this point one of the door watchers from earlier just randomly explodes. He hadn't moved in nearly 20 turns. If it explains everything, 2 turns later the rest went off, and the remaining, confused bunch went home. Perhaps, they thought, he just had been waiting to go since they left, and this was just the unfortunate side effect. Screenshot if it means anything.

http://steamcommunity.com/sharedfiles/filedetails/?id=1335285579

[ X:CE 0.34.3] The Void

Randomly during a UFO mission there was just an 24ish tile area that decided not to exist. Ultimately it was just a minor inconvenience, but here is a screenshot.

http://steamcommunity.com/sharedfiles/filedetails/?id=1333480853

[ X:CE 0.34.3] Cruiser Confuser

There is a bug I had seen a few times involving the cruiser being fully black on it's bridge. Apparently for some this was solved by removing walls, but this didn't seem to work when I tried it. Two other times it had. I don't know what the implications of this are. 

http://steamcommunity.com/sharedfiles/filedetails/?id=1332683611

Share this post


Link to post
Share on other sites

Hello, while I'm playing on [0.34.1] without any added Fix Pack, I'd have some comments.

  • C4 Glitch
On 18/03/2018 at 9:30 PM, Coffee Potato said:

No sarcasm meant, can you positively assert that there was no Wraith with plasma canon somewhere in the starting room, out of LOS? I guess not because you triggered the situation several times. Also, how about a door bug instead, the plasma bomb being fired from the other side, without destroying the door. In short was the C4 triggering really the reason why this explosion?

  • Black, walkable tiles
On 18/03/2018 at 9:30 PM, Coffee Potato said:

I've already encountered this bug. I'll try and hunt these very tiles (or map parts) from now on, in case they are an oversight in some terrain packs? Perhaps they are only not trackable corruption?

On the other hand, I encounter them much more when environment was destroyed, certainly while map is generated, and perhaps while playing as well. They always are still walkable tiles, even when on a higher level (building store, UFO bridge). I play with "Fire in the Hole" and enhanced terrain resources mods, and included better crash site, and it looks like some Carrier maps are often bugged, when the UFO took heavy damage in the crash. I don't know if these tiles were deemed destroyed or otherwise.  While several mods deal with crash sites and could be the cause, perhaps if so, they could also help to find the cause in case of normal terrain tiles (see screenshot).

  • Hidden Cruiser bridge
On 18/03/2018 at 9:30 PM, Coffee Potato said:

[ X:CE 0.34.3] Cruiser Confuser

There is a bug I had seen a few times involving the cruiser being fully black on it's bridge. Apparently for some this was solved by removing walls, but this didn't seem to work when I tried it. Two other times it had. I don't know what the implications of this are. 

http://steamcommunity.com/sharedfiles/filedetails/?id=1332683611

I've never encountered this bug so far (X:CE 0.34.1, Fire in the Hole, all the packaged terrain resources, embedded better crash sites). I read it has been reported several times, however.

 

xeno_blackTilesCarrier.png

Edited by Rodmar18
Added a screenshot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×