Charon

[1.65/X.CE V0.34.3] X-Division 0.99 Beta

2,138 posts in this topic

In the latest weeks i have  I have seen an high increase in our presence on youtube. I have compiled a list for the THIS IS SPARTA thread to help people and give them new ideas. Here it is:

1.1 Youtubers and Lets PLay

Some people have picked up the game on youtube and may be able to teach you a thing or two. If you are stuck, looking for new ideas or simply want to get entertained, this is the place for you.

Mulligan: ( Veteran/Ironman ) ( English )
Season 1: https://youtu.be/8kYalOes-LQ
Season 2: https://youtu.be/MgO67x5mIJA ( recommended )

Lambert2191: ( Normal/Ironman ) ( English )
Season 1: https://www.youtube.com/watch?v=fNk3w51eJbY&list=PLxx5-blJHlBBVo-w3Abkv7OWfvExzLRqe
Season 2: https://youtu.be/Ia25rwVBHx8?list=PLxx5-blJHlBBeda18IeaiW0H1yyN2JlLR ( recommended )

VenTronixx: ( Easy/Ironman ) ( German )
Season 1: https://youtu.be/T16jF_KDIXE

The Seeker Group: ( Normal/Ironman ) ( Russian )
Installation video: https://youtu.be/J-y9HX221PE
Random Streams: https://youtu.be/pOoSK02o_d4https://youtu.be/cqBkprjLInMhttps://youtu.be/S9pxOTayX9o,
Season 1: https://www.youtube.com/watch?v=ta757y5jdBs&list=PLTtg5eMzQco-_A4oJsWdpVdOK6eV-lVi3 ( recommended )

 

 

1.2 Indepth Game Explanations on Youtube

Molnar Paul Lucian: ( Veteran/Ironman ) ( English )
Season 1: https://www.youtube.com/watch?v=-0OhqtyEF1s&list=PLaFz18QmoP8ircOIp1_twHyFVbnSoCX_0

Share this post


Link to post
Share on other sites

Looks like I fixed my problem of vehicles phase 3 & 4 weapons not spawning when producing them. I deleted my  C:\Users\Username\AppData\Roaming\Goldhawk Interactive\Xenonauts\internal file as you recommended in your main post, and I properly applied the hotfixes in the  4. Known Bug by putting them into the X-Division 0.99 Beta mod folder in the assets folder. Smooth sailing so far.

In my broken save, I noticed that whenever an alien threw an advanced alien neutron grenade, it would crash my game. I'll see if I run into it again with my improved patched version.

1 person likes this

Share this post


Link to post
Share on other sites
18 minutes ago, Fenoftal said:

Hello forum users and the developers of great games!
I have a question! The accuracy of my soldiers is reduced when they are sitting, why?
There has to be the opposite, or am I mistaken? The screenshots below

Xenonauts 2017-02-12 10-48-02-28.bmp

Xenonauts 2017-02-12 10-51-31-49.bmp

I checked it, and it works as intended, crouch is a +20% increase in accuracy.

So this means if you have 30% chance to hit and crouch, its 36%.

I looked at your pictures, and the change you see cant because of the crouching, so something else may be interfering. Try it out on other occasions too and you will see it works correctly, but there might be inteferences in this case ( smoke, obstacle that gets wrongly calculated, ... )

Share this post


Link to post
Share on other sites

Please check it with very high-maximum accuracy numbers. I think cause in it.

Share this post


Link to post
Share on other sites
5 minutes ago, Pandi said:

Please check it with very high-maximum accuracy numbers. I think cause in it.

?

There are only numbers available between 5 % and 95 %. At 20 % its 24%, at 40% its 48%, at 60% its 72%, at 80 its .. 95%.

Share this post


Link to post
Share on other sites

I expirienced this (crouch % drop) when trained accuracy at max. In clear field without smoke or obstacles... It max (95%) when stand and drops when crouch. So behind this no so simple.

Share this post


Link to post
Share on other sites
7 minutes ago, Pandi said:

I expirienced this (crouch % drop) when trained accuracy at max. In clear field without smoke or obstacles... It max (95%) when stand and drops when crouch. So behind this no so simple.

hm ... i will look into that issue, but even if we confirm it theres not much i can do, i guess, other than giving it to @Solver. A video would be welcome.

Share this post


Link to post
Share on other sites
50 minutes ago, Pandi said:

I expirienced this (crouch % drop) when trained accuracy at max. In clear field without smoke or obstacles... It max (95%) when stand and drops when crouch. So behind this no so simple.

@Solver and I are on it:

 

Share this post


Link to post
Share on other sites

Hi i just started a new game with this mod and the first thing i was doing is looking at all the menus and the change equipment one crashes the game any reason for this?

 

Thanks

Calum

Share this post


Link to post
Share on other sites
12 minutes ago, blackwind said:

Hi i just started a new game with this mod and the first thing i was doing is looking at all the menus and the change equipment one crashes the game any reason for this?

 

Thanks

Calum

3.3 Troubleshooting

This mod is %98 stable. If you got any weird problems like aliens without guns, strange visual errors, game crashes, they should be about wrong install or mod loader issues. Be sure that you got X:CE, X-Division and X-Division Patch is installed and then come to our topic with your save game and we will help you. 

Sincerely yours, Drages

I think i got a bug, can you help me ?

If you want some help when you make a bug report or think that something is not the way it is supposed to be, add full screenshots of your whole modloader and your savegame ( geoscpae only ).

Share this post


Link to post
Share on other sites
18 minutes ago, blackwind said:

Hello heres the load order and save for my Soilder equipment new game crash thanks for the help :)

Xenonauts load order.jpg

test.rar

58a0ce1e4b90f_Xenonautsloadorder.thumb.jpg.aeec020b94607d0b313c168934fde199.jpg

 

And i would move out the mods that you didnt install, actually.

Share this post


Link to post
Share on other sites
21 minutes ago, Charon said:

58a0ce1e4b90f_Xenonautsloadorder.thumb.jpg.aeec020b94607d0b313c168934fde199.jpg

 

And i would move out the mods that you didnt install, actually.

i Changed load order to the same as load order in 7. made no diffrence also tryed turning part 2 off still made no differance. I made sure to delete the scripts in appdata after doing this

Edited by blackwind

Share this post


Link to post
Share on other sites
2 minutes ago, blackwind said:

i Changed load order to the same as load order made in 7. no diffrence also tryed turning part 2 off still made no differance. I made sure to delete the scripts in appdata after doing this

Always show me the modloader.

Share this post


Link to post
Share on other sites

I actually have the same issue, crashes anytime i click on the equipment menu. I used to play this mod a lot and never had this issue 

Also idk if it's related but i have this weird ass bug at the main menu

Screenshot (38).png

20170213104042_1.jpg

Edited by blaze1984
More bugs

Share this post


Link to post
Share on other sites
3 minutes ago, blaze1984 said:

I actually have the same issue, crashes anytime i click on the equipment menu. I used to play this mod a lot and never had this issue 

 

Screenshot (38).png

So what changed ?

Did you clear your scripts folder ?

Share this post


Link to post
Share on other sites
4 minutes ago, Charon said:

So what changed ?

Did you clear your scripts folder ?

The only thing that changed was me downloading the latest patch, I already cleared my scripts folder before and after installing and I just did it against to be extra sure, still the same 2 issues

Share this post


Link to post
Share on other sites
3 minutes ago, blaze1984 said:

The only thing that changed was me downloading the latest patch, I already cleared my scripts folder before and after installing and I just did it against to be extra sure, still the same 2 issues

Why do you have mods below the XCE ones ? Does the autosort message pop up ? What do you click ?

Share this post


Link to post
Share on other sites
2 minutes ago, Charon said:

Why do you have mods below the XCE ones ? Does the autosort message pop up ? What do you click ?

I remember getting the autosort message a while back, when i played the mod like 4 months ago, but i don't get it anymore and idk where to put those 2 disabled mods so i left em there

Edited by blaze1984
d

Share this post


Link to post
Share on other sites
6 minutes ago, blaze1984 said:

I remember getting the autosort message a while back, when i played the mod like 4 months ago, but i don't get it anymore and idk where to put those 2 disabled mods so i left em there

Can you give me some more info, screenshots, anything that could help ? Im pretty much in the dark right now. Operating system, platform, everything that could help. Gimme some screenshots from inside the game.

All i know that if people install it normally, it functions, even the russians without any english skills got it perfectly.

Share this post


Link to post
Share on other sites
14 minutes ago, blaze1984 said:

I remember getting the autosort message a while back, when i played the mod like 4 months ago, but i don't get it anymore and idk where to put those 2 disabled mods so i left em there

If you are on Steam, can you come online ? The name is Charon, search for the group X_Division, im the administrator there.

Share this post


Link to post
Share on other sites
5 hours ago, blaze1984 said:

I actually have the same issue, crashes anytime i click on the equipment menu. I used to play this mod a lot and never had this issue 

Also idk if it's related but i have this weird ass bug at the main menu

Screenshot (38).png

20170213104042_1.jpg

For all guys having this issue:

Unfortunately we couldnt find the cause for this, but we managed to fix it by simply making a very clean install, starting by removing every xenonaut file we could find, and letting steam install it again and then just follwoing the path of a normal installation.

This proves again that a clean install always produces a working game.

Edited by Charon

Share this post


Link to post
Share on other sites

the x-div heavy interceptor causes insta crash on manual air battle :) also it dont have image on hangar etc, but im sure you already known this :)

also spiritwolf mech can use timberwolf pulse that cause its Ground combat model to change to a IFV apc :)

awsome work on the mod love all the new things

i noticed no other crashes other than that one.

my load:

modload.png

Edited by asierus24

Share this post


Link to post
Share on other sites
1 hour ago, asierus24 said:

the x-div heavy interceptor causes insta crash on manual air battle :) also it dont have image on hangar etc, but im sure you already known this :)

Jup we do.

1 hour ago, asierus24 said:

also spiritwolf mech can use timberwolf pulse that cause its Ground combat model to change to a IFV apc :)

You discovered the hidden transformer ! Congratulations :)

1 hour ago, asierus24 said:

awsome work on the mod love all the new things

i noticed no other crashes other than that one.

my load:

modload.png

looks good, only the Xenonauts Fix Pack should in theory be below 7, but if it works its ok.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now