Jump to content
Sign in to follow this  
Gam

{V1.53 Stable - Mod not working anymore]

Recommended Posts

Hi,

I know this is mod related and I have managed to patch the problem, anyway...

The attached file is the Xenopedia with Italian translation.

If this file is left in the mod as is, the game crashes after the positioning of the first base.

If I remove the last column, the game works ok.

But the file has been like this for a long time and I need to keep the last column for comparison and records.

Also, if the file is replaced manually in the assets folder, everything works fine.

Could you help me understand what is wrong with it?

Thanks

Gam

xenopedia - con inglese.zip

xenopedia - con inglese.zip

xenopedia - con inglese.zip

Share this post


Link to post
Share on other sites

Bumping it up.

Also, I have just realized that the translation of the gcloading_tips does not work either.

I am not sure if it has actually ever worked with the new workshop system.

Has anyone else experienced this?

Gam

Share this post


Link to post
Share on other sites

I presume you are using this with the new mod-loader? If so, the reason why it is crashing is because the first row of the file needs to be exactly the same as the first row of the vanilla file. Since the added column isn't in the vanilla file, it mismatches and breaks.

Without changing how the mod-loading system works, I don't think there's any way to work around this other than the solution you've already found. Best bet then is probably to upload/use a version without the additional column but keep a separate copy in storage with the added column.

(Actually, a thought: try removing the column header for the extra column but keep all the other cells in that column. That might work, as it might stop the game from trying to merge the extra column.)

Share this post


Link to post
Share on other sites

Ah, no. I know what the problem is. Because the file uses the same element multiple times (i.e. <tip>) the mod-loader can't tell which one needs updating and fails. Since you don't need to care about merging this with other mods to that file, it would be easiest simply to use the "replace" command to update the whole file. So just change the top element to read as follows:

<GCLoadingTips MODMERGE="replace"> rather than just <GCLoadingTips> and that should do it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×