Results 1 to 6 of 6

Thread: Crash while parsing Soldier name XML: SoldierNameGenerator::SoldierNameGenerator

  1. #1

    Crash while parsing Soldier name XML: SoldierNameGenerator::SoldierNameGenerator

    I downloaded the package Xenonauts.2.dmg (V13.02) off Desura.com and after installing it (drag and drop into the applications folder), it's crashing immediately when I run it. Seems like the solder name xml is not in the right place. The crash reports says it's dying while parsing the XML. I'm using Mac OS X 10.7.4 (11E53)

    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0 com.centrecirclestudios.xenonauts 0x0024817f TiXmlNode::FirstChildElement() const + 47
    1 com.centrecirclestudios.xenonauts 0x001d5ebd SoldierNameGenerator::SoldierNameGenerator(bool) + 185


    See the whole thing here:

    http://pastebin.com/bNqPcVfA

  2. #2
    Moderator Gauddlike's Avatar
    Join Date
    Oct 2011
    Location
    Leicester, UK
    Posts
    5,486
    There have been similar problems before caused by corrupt downloads.
    Sometimes, due to the number of tiny little files, one or two of them get lost in the process somewhere.
    If possible can you try downloading the file and extracting again and see if that helps?
    Devil's Advocate and forum moderator

  3. #3
    I downloaded the dmg again and got the same error. What XML file is the executable expecting and what permissions does it need to be? I found these files..

    $ ls -al /Applications/Xenonauts.app/Contents/Resources/assets/assets/soldier*.xml
    -rw-r--r-- 1 akirarat admin 12597 Feb 15 2012 /Applications/Xenonauts.app/Contents/Resources/assets/assets/soldiernames.xml
    -rw-r--r-- 1 akirarat admin 8624 Jun 4 22:06 /Applications/Xenonauts.app/Contents/Resources/assets/assets/soldiernamesfemale.xml
    -rw-r--r-- 1 akirarat admin 1066 Feb 15 2012 /Applications/Xenonauts.app/Contents/Resources/assets/assets/soldierprops.xml

  4. #4
    Moderator Gauddlike's Avatar
    Join Date
    Oct 2011
    Location
    Leicester, UK
    Posts
    5,486
    Might be an idea to post this in the mac specific bugs sticky as well.
    ko2fan might have come across something similar.
    http://www.goldhawkinteractive.com/f...-reports/page4

    The file structure is not the same as mine but I am using a windows version so that could be the reason.
    soldiernames, names female and props are the only ones I have as well in my assets folder.
    Have you opened those files to see if they have anything in them?
    I had a problem with a previous version where the files were empty, think that was a Desura update problem though.
    Devil's Advocate and forum moderator

  5. #5
    Art Lover Max_Caine's Avatar
    Join Date
    Nov 2011
    Location
    Angleterre
    Posts
    3,560
    I can see your problem - this has already been raised in the mac bug report thread. You need to move everything from /assets/assets/ up one directory to /assets/. There shouldn't be /assets/assets/.

  6. #6
    Sergeant ko2fan's Avatar
    Join Date
    Oct 2011
    Location
    St. Louis, MO
    Posts
    159
    Please keep bug reports for mac in the sticky thread or else I wont see them.

    Max_caine is correct.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •