Sign in to follow this  
Followers 0
oracle1990

[V13] - Ground Combat - Crash to desktop

27 posts in this topic

When I have shoot down the first UFO and try to engage in Ground Combat, the game crash to desktop. Happen 5 times out of 5 tries.

I play Full Game, Normal setting, no mods (new computer).

I tried Full Game, Easy setting, ignore first ground site and went to next ground site - game crash...

Update. The game crash on Quick battle too...

--O--

Edited by oracle1990
tested several times

Share this post


Link to post
Share on other sites

Can you validate all your files on Desura please? It shouldn't do that. It may be an issue with the files being downloaded incorrectly.

Share this post


Link to post
Share on other sites

Same problem here...

Validated the files: everything is fine

Running Windows 8 RP 64bit on an AMD Phenom II X4 955 with a ATI Radeon HD 5770 1GB

Edit:

Am uninstalling and downloading again, to see if something went wrong with the update process

Nope, even after completely installing it again: CTD on initiating ground combat.

I do get to see the loading screen for 1 or 2 seconds then CTD

Edited by Kierian
new action

Share this post


Link to post
Share on other sites

Are you shooting the UFOs down in the desert? maybe the game is trying to fetch non existent maps?

(Chris is the desert type maps added to the geoscape mesh? I'm wondering if community mappers can add their own desert maps in deserts yet or if the desert maps has to be put in between the industrial or farm map types.)

Edited by Gorlom

Share this post


Link to post
Share on other sites

Bug: CTD when attempting to initate ground combat with a crashed ufo

Conditions attempted: Using the inital set-up of soliders and loadout provided. Attempts to initate ground combat over farmyard in night conditions, farmyard in day conditions, industrial in night conditions, industrial in day conditions (as according to the geoscape detail readout) with a light scout.

Steps to reproduce: 1) Start a new game. 2) Wait for a ufo to appear. 3) Shoot down ufo. 4) Send Chinook to crashed ufo. 5) Click to engage. Loading screen appears, crashes after loading screen disappears.

Share this post


Link to post
Share on other sites

Uninstalled Xenonauts. Reinstalled. Same error. Not able to get any Ground Combat.

Same error in Debug mode.

Edited by oracle1990

Share this post


Link to post
Share on other sites

Has anybody tried skipping time to the point that Scouts appear, rather than Light Scouts, just to see if it's an issue with the Light Scout crash site?

Share this post


Link to post
Share on other sites
Can you validate all your files on Desura please? It shouldn't do that. It may be an issue with the files being downloaded incorrectly.

I have validated the files. Still the same error.

Has anybody tried skipping time to the point that Scouts appear, rather than Light Scouts, just to see if it's an issue with the Light Scout crash site?

Try to skip to first Scout - same error.

--O--

Share this post


Link to post
Share on other sites

I fiddled with the ticker to bring the normal scout up first and it doesn't make any difference. The gc is rejecting something or looking for something that makes it crash... but what?

Share this post


Link to post
Share on other sites

This is very strange. The Build v13 that should have been uploaded works fine on my PC. I'll download the version from Desura and see if that works - if not, I'll try re-uploading everything.

Share this post


Link to post
Share on other sites

Does anyone have a standard pre-order and confirm that this is happening to them too? I uploaded it seperately to both branches so I'm wondering if there was an issue in one of the uploads?

Share this post


Link to post
Share on other sites
Does anyone have a standard pre-order and confirm that this is happening to them too? I uploaded it seperately to both branches so I'm wondering if there was an issue in one of the uploads?

Yes, I can confirm that the game immediately crashes when trying to engage in ground combat. Air combat seems fine though.

Share this post


Link to post
Share on other sites

I to am having the same issues as described in the first post and I have have only just downloaded it.

Edited by mace6442

Share this post


Link to post
Share on other sites

I noticed the industrial maps are missing from the "maps" folder and "levelsetup" refers to them. I don't know if this could be causing it.

Also if you try to load up a map in the level editor, an error occurs saying it cannot get the spawnmaps and targetmaps.

Edited by Khall

Share this post


Link to post
Share on other sites
I noticed the industrial maps are missing from the "maps" folder and "levelsetup" refers to them. I don't know if this could be causing it.

Also if you try to load up a map in the level editor, an error occurs saying it cannot get the spawnmaps and targetmaps.

This is almost certainly the error. I'm at work for the next 6 hours, but when I get home I still have the files from before the update on my other computer. I will try to copy them to the latest version to see if the program will work once the maps are present.

Share this post


Link to post
Share on other sites

OK, I think I've got this fixed up now. For some reason the uplaod didn't grab all the files it was meant to. Only problem is, the Desura guy went offline literally three seconds before I sent him a message asking him to approve the patch. So we might be waiting a while for the hotfix to be approved...

Share this post


Link to post
Share on other sites

Levelsetup.xml appears to have everything commented out, as expected, so I doubt that is what's causing it. I'm not sure what the missing 2.5mb of files are but hopefully the new patch will fix it up when released.

Share this post


Link to post
Share on other sites

I have standard pre-order and can confirm that when i send my unit to engage in mission at ground site after downing ufo it CTD's. what exactly is a while? a couple of days?

Edited by bushidoblaze

Share this post


Link to post
Share on other sites

A while is a while. It's whenever the Desura guy comes back on, notices the message, then actions it.

Share this post


Link to post
Share on other sites
This is almost certainly the error. I'm at work for the next 6 hours, but when I get home I still have the files from before the update on my other computer. I will try to copy them to the latest version to see if the program will work once the maps are present.

Yes, I had been playing with the level editor the last two days and I see that submaps are missing in Industrial and Farm, for example. Also, most levels fail to load in the editor.

Does anyone have a standard pre-order and confirm that this is happening to them too? I uploaded it seperately to both branches so I'm wondering if there was an issue in one of the uploads?
I have standard pre-order and can confirm that when i send my unit to engage in mission at ground site after downing ufo it CTD's. what exactly is a while? a couple of days?

Standard pre-order and same error here.

Edited by Orumo
Poor English...

Share this post


Link to post
Share on other sites

tried here as well, CTD in quick battle CTD in ground combat in campaign mode as well

Edited by raziel1981

Share this post


Link to post
Share on other sites

The update that's just gone out should fix this now, hopefully.

Share this post


Link to post
Share on other sites
The update that's just gone out should fix this now, hopefully.

Ground Combat is working now. Tested both Quick Combat and Full Game.

--O--

Share this post


Link to post
Share on other sites

i can validate it too, ground combat seems to be working fine both in quick battle and full campaign

Share this post


Link to post
Share on other sites
The update that's just gone out should fix this now, hopefully.

Nice and quickly fixed Chris, but doesn't Desura's upload mechanism do an automatic verification with the folder you upload?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0