Sign in to follow this  
Followers 0
Moxar

[V12.1] Invisible alien

18 posts in this topic

Hi (again)...

This bug occurred in the last build, but still:

sometimes, aliens are invisible (the red icon is here, and you can shoot at him, but the sprite is invisible). However, when the alien dies, the sprite of death and the body are here.

Moreover, the soldier who spoted the alien "sees" him, even if he looks on the opposite direction after.

I made a few screenshots, but I can't find them on my CPU... Where are they kepts by xenonauts ?

Share this post


Link to post
Share on other sites

We have had this before a few builds back.

If there is an invisible alien it's most likely the sprite is missing or the path to it has a typo. Could you please tell us which alien it is? race, rank and weapon it is carrying are all important as the three of them together determine which sprites are used.

Share this post


Link to post
Share on other sites

Yep, I've been having this since about 4 or 5 versions back.

I don't think it's as simple as a missing sprite, as it often occurs right next to an actual alien, and it occurs midway through a game. Sorry, it's tough to explain but, imagine this:

A Xenonaut trooper closes towards a crashed Scout and in doing so, spots a lone Sebillian. There's no error at this time. The Xenonaut shoots and hits the Sebillian with no issue. End turn.

Next time it's the players turn, he selects the same Xenonaut and goes to take a second shot. However, his line of sight to the Sebillian he previously shot, who hasn't moved, is blocked. When the player moves his cursor one tile away from the Sebillian, towards his Xenonaut who's lining up the shot, he sees that the game is registering a second target directly in front of the lone Sebillian.

There's clearly nothing visible though. He has a hit % displayed on this phantom target, and so takes the shot...

Now; at this point I've had one of two things happen:

- The shot is simply absorbed.

- The shot disappears into the empty target, and the original actual Sebillian dies.

Sorry, that's the only way I can describe this issue. It happens to me a hell of a lot.

Share this post


Link to post
Share on other sites

That doesn't seem to be the same problem though jimbob, the OP says a corpse shows up. And gives the impression that the xenonaut spotting the invisible alien (as in showing icon) without any other alien there. Since last time you mentioned this I believe you said that the ground battle could end without killing these phantoms of yours?

Jimbob is your phantom alien showing a shadow? Moxar, is yours?

Share this post


Link to post
Share on other sites

My phantom alien is here, I just can't "see" him on the screen, but I can kill him. He is showing a shadow.

I got more informations (this bug just occured):

Caesan guard corpse

wearing Heavy plasma

Facing North-West before dying (He fell facing NW).

Edited by Moxar

Share this post


Link to post
Share on other sites

You may be right then Gorlom, there's no shadow in the example I described, so maybe it's a different issue. I'll keep testing.

Share this post


Link to post
Share on other sites

Maybe take a screenshot? Perhaps a new breed of alien :)

Share this post


Link to post
Share on other sites

ofc, I took I screenshot... But I cant fine the dir the screenshots are saved. (Using Windows 7). Do someone knows ?

Share this post


Link to post
Share on other sites

I'm not sure this is related but i'm having a similar problem in build 12.11 - I can see a shadow of the alien on the floor, but their's no alien. At the same time their are other aliens in the same ground mission that do appear. After a few turns it ended in my computer being frozen and having to cold boot. Since build 12.0 it seems that the builds are only getting less stable from version to version :(

(using win 7 too. my rig is a Asus rampage III formula, core i7 950, HD 6950 crossfire, 2X OCZ Vertex 2 60GB @ Raid 0)

EDIT: I ran into the invisible alien once again and killed one of them. When standing over the corpse its name was a "Haridan" or something of that sort, so indeed we're talking about a new alien with missing sprites.

Edited by raziel1981

Share this post


Link to post
Share on other sites

Okay, I've just had this issue multiple times and there's definitely no shadow beneath the phantom for me. Also, I've set the number of occupants for the UFOs to always spawn the same number of enemies, and each time I can account for that number of aliens and the phantom target appears above and beyond that number, so I don't think this is a case of an alien being present but without the correct sprite. Does the shadow move in your games? If so then yeah, that's definitely missing sprites. The fake target in my experience never moves or does anything. This is a real mystery...

Share this post


Link to post
Share on other sites

dis things moves, shoots, and kills ma boyz. Mast be a facehugger! Raaaahhhhhhh! I'm gonna kick your ...

*voice fading beneath the deadly sound af a Machinegun*

Share this post


Link to post
Share on other sites

I get this bug for Xenonauts after searching the farm buildings on a field UFO crash sites...

Trying to upload screenshot, but cannot get it to work? It goes to max. of the upload and then nothing...

Share this post


Link to post
Share on other sites

just use a image depot site and hotlink it.

Also I encountered this last night, once you kill this shadow alien it does become visible at least.

Share this post


Link to post
Share on other sites

http://i.imgur.com/TAydG.jpg

So the forums uploader neither would accept imgur or imageshack... So you just get a link...

If the soldier is not selected and/or you have the cursor over the soldier, they can be really tricky to find..

just use a image depot site and hotlink it.

Good idea, thx :)

Edited by bloodlazio

Share this post


Link to post
Share on other sites

My shadow aliens move, and die, leaving a corpse. Will check the type and what weapon it's carrying next time. I've seen it happen 2 time. AFAIK they did not fire at me.

*edit* happened again last night, have some screenshots this time. Will opload when I'm home. Now I can confirm one of 2 encountered shadows on a map shot at me, thus they are functional. The issue is cosmetic.

Edited by dekamme

Share this post


Link to post
Share on other sites

In the first pic I highlighted the alien shadow. The next one targetting him, then his corpse. In the last one I had a soldier standing on top of him, so you can see what type of alien it is.

Shadow07combined.jpg

For those who don't know how to make a screenshot:

Ingame press "print screen" on your keyboard

ALT-TAB back to windows

open a picture editor (like Paint)

Paste (ctrl-v)

Save as jpg

Shadow07combined.jpg

Shadow07combined.thumb.jpg.a4d9d32d3dae1

Share this post


Link to post
Share on other sites

I thought the invisibility might be a feature, since a mind control was attempted immediately before. All I could see was that he had a red head, don't think it's the Leader since he wasn't in the command center. Since this was so unusual, we tried to beat him down with batons, game CTD. :(

Correction: it was the Leader.

Edited by screeg

Share this post


Link to post
Share on other sites

Please don't resurrect bug threads from two years ago - this was a bug in a build long ago. Please create a new one if you're experiencing this in V1.09. If you are, please also provide a save game from the mission if possible so we can try and recreate the situation.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0