PDA

View Full Version : [V8.41 Geoscape] Load game with a crashed UFO crashes the game V 8.41



chichomr
12-15-2011, 02:50
I shot down 2 UFOs. Went to the first, went back to base and saved the game before going to second crash site. I could load that save game twice, but now every time I load it in play mode the game crashes. If I load it in debug mode, it loads OK.

I've attached the save games. It's the one named "3".

Sathra
12-15-2011, 03:41
Ah damn. I thought this was fixed.

Chris
12-15-2011, 09:47
Yup, I'm also getting this crash. Just to confirm, everything here took place in V8.41 and you're not using any save games from prior versions?

chichomr
12-15-2011, 17:03
Hi, I just started playing in V 8.41 so this are new save games created with this version of the game.

Chris
12-15-2011, 18:11
OK cool I've passed the save game onto the programmer.

Inukshuk
12-15-2011, 21:52
I am playing 8.41 and I certainly have this problem. However, I often get crashes when saving and/or loading just about any game. I have deleted all old save many times and that seems to make no difference. Typically I can save two or three times before reloading crashes the game and once that happens, I can't reload and of the previous saves either. Sometimes clearing out registry errors helps, sometimes not. If a save involved interceptors in the air on the way to a UFO, it increases the odds the save won't work but that's not always the case. Also true is that it is safer to try to save when the Chinook makes it back to base. many times (in 8.41) I'll finish a mission, try to save on the way home, and the game will crash. There's a save game entry created, but it is never reloadable and often seems to undermine the reloadability of previous saves.

Chris
12-17-2011, 08:40
Yeah, we've had similar issues. Once a save game crashes, it's not loadable any more until I restart my PC. We've done some work on the save feature and hopefully it'll be a bit better come next build.

BugPowderDust
12-19-2011, 06:58
Ive just experienced something similar not sure if it's the same?

I had an autosave, which had an alien ship flying. I intercepted, shot down the craft, then realised I didn't have a transport chopper (been shot down previously), so I quit the game and clicked New Game. When I started, the "Crash Site-1" icon was hovering in mid air, and wasn't anchored to the map. I tried to send my transport chopper to 'intercept' the 'site', when I clicked on the site as a target, the game CTD.

I can create a new thread if you like, but thought it sounded like this one so didn't want to duplicate.

Sathra
12-19-2011, 07:06
That's a different one I think. One of the Ghost UFO bugs. I thought that had gotten fixed.

Chris
12-19-2011, 07:37
Nah it's still in V8.41 but should be fixed in the next build, as soon as we fix an autosave crash.